2

In QGIS 2.2.0, while adding vector layer, 'ESRI FileGDB' option was missing under Source-Type, refer the attached screenshot.In this case, how can I attach a file GDB in QGIS 2.2.0?

enter image description here

1 Answer 1

2

If you have followed these instructions:

File Geodatabase (*.gdb) support in QGIS?

you should be able to load the gdb directory (and layer) in the dataset text box.

5
  • Interesting, I've installed QGIS on the machine with ArcGIS installed and haven't done any additional configuration. I have fileGDB option enabled by default. How come? Commented Mar 7, 2014 at 13:25
  • @Alex Tereshenkov - Qgis can read the GDB format if only GDAL/OGR libraries are configurated/compiled to read the GDB API that must be installed and also made available. So I think in your case both things are true. Commented Mar 11, 2014 at 12:36
  • yeah, probably these components were installed automatically with ArcGIS Desktop installation. Thanks for letting me know! Commented Mar 11, 2014 at 13:36
  • @MickyInTheSky I checked your suggestion. (1) During installation using QGIS-OSGeo4W-2.2.0-1-Setup-x86.exe, there is no such option was available to select/enable gdb components. (2) After installation, while adding vector layer using the 'source-type' value as 'UK.NTF2' and a fileGDB as dataset, It shows an error message 'Invalid data source'. How to fix this issue? Commented Mar 13, 2014 at 12:53
  • you should use the net installer, as recommended in the link above.download.osgeo.org/osgeo4w/osgeo4w-setup-x86.exe Commented Mar 13, 2014 at 14:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.