1

Using 2.2.0-Valmiera on Ubuntu 13.10

I have for Croatia 21 Counties as polygons. Labels show only for 12 counties: here I see that no labels are shown for multipart features. So I checked "Show labels for multipart features": No change I unchecked "Discourage labels from covering features: No change

I tried a layer with all Municipalities cca 500 polygons. Labels show for most polygons but not all. All multipart polygons failed to show labels.

Then I found out that this behaviour of is dependent of the scaling. At 1:25000 all labels show, also on multipart but at 1:50.000 part of the labels are not shown. I controlled: - Scale based visibility : unchecked so okay - Topology: No errors - Geometry validity: no errors

Has anyone seen this behaviour and perhaps know a solution

Thanks

1

This is a known issue for the QGIS 2.2 release. It has recently been fixed, but not backported to 2.2 release, yet. However, you can temporarily work around the issue by turning Simplify geometry to OFF for the layer (under Rendering in Vector Layer Properties).

If that does not fix your issue, then you may have a number of polygons with invalid geometry. Try running the Vector -> Geometry tools -> Check geometry validity command in the main menu. Invalid geometries may be rendered, but not necessarily labeled, so you would need to fix your data.

You can try to fix any invalid geometry using the Processing LWGEOM Provider plugin, which has a Make Valid command. Otherwise, you may have to manually fix problematic polygons.

  • Turning Simplify geometry to OFF worked perfectly. Thanks a lot! – user22164 Mar 8 '14 at 15:14
0

Clicking on the labelling icon, you have a Rendering tab at the bottom.

There you can check Show all labels for this layer

And in the Feature Options below you can also check or uncheck some more options.

  • I have done that and still the same behaviour.... Interesting is that when I press Toggle Editing for the layer the label appears. Also when the scale is 1:25000 and below. – user22164 Mar 7 '14 at 16:01
  • I also tried changing the Text from a point size to map units but still same. – user22164 Mar 7 '14 at 16:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.