3

We got some files (*.sdx) from our clients using sdeexport from ArcSDE 9.3. We only have ArcSDE 10.1. We tried to use sdeimport command like this:

sdeimport -o create -t NHDFCODE -f c:\temp\NHD.NHDFCODE -v -i sde:oracle11g:**\** -u sde** -p **. 

When run this command, there is the only message we see:

Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

ArcSDE 10.1  for Oracle11g Build 679 Thu Apr  5 11:43:21  2012
SDEX File Import         Administration Utility
-----------------------------------------------------

Since I cannot tell what was going on based on this,I am just wondering if we can import the sdx file from ArcSDE 9.3 to ArcSDE 10.1. Thanks.

Update:

sdexinfo -o describe -f c:\temp\NHD.NHDFCODE
------------------------------------------------------------------------
SDEX File:             c:\temp\NHDNHDFCODE.sdx
Version:               SDEX 10.0.0_1
Type:                  Final
Volume Type:           Single

SDE Attribute Columns: 15
Name                                 Type    Width numDecimal  NULL?   RowID
-------------------------------- ----------- ----- ---------- -------- -----
OBJECTID                         SE_INT32       10      0     NOT NULL  SDE
FCODE                            SE_INT32       10      0     NOT NULL
DESCRIPTION                      SE_NSTRING    255      0     NOT NULL
CANALDITCHTYPE                   SE_NSTRING     32      0
CONSTRUCTIONMATERIAL             SE_NSTRING     32      0
HYDROGRAPHICCATEGORY             SE_NSTRING     32      0
INUNDATIONCONTROLSTATUS          SE_NSTRING     32      0
OPERATIONALSTATUS                SE_NSTRING     32      0
PIPELINETYPE                     SE_NSTRING     32      0
POSITIONALACCURACY               SE_NSTRING     32      0
RELATIONSHIPTOSURFACE            SE_NSTRING     32      0
RESERVOIRTYPE                    SE_NSTRING     32      0
STAGE                            SE_NSTRING     32      0
SPECIALUSEZONETYPE               SE_NSTRING     32      0
KCODE                            SE_NSTRING     30      0     NOT NULL
7
  • How large are the files? Have you tried using "sdexinfo" to validate the file integrity? Have you looked in the database to see if the table has been created?
    – Vince
    Mar 7, 2014 at 14:45
  • The file I tried is only 20k. The file is ok when checked with sdexinfo. and there is no such table created in DB. Thanks.
    – Alex
    Mar 7, 2014 at 18:59
  • I don't think the client connected. Does 'sdelayer -o describe' work using the same connection properties? Is there a firewall in place? Are you using the 64-bit Oracle client with the 64-bit binary? The export file indicates the source is 10.0, not 9.3. An 'sdexinfo -o stats' will scan the entire file for validity.
    – Vince
    Mar 7, 2014 at 19:18
  • It is likely the connection is the problem. We can access the SDE with ArcCatalog. But I just realize ArcSDE command need its own ArcSDE service. am I right?
    – Alex
    Mar 12, 2014 at 14:40
  • No, all command-lines tools are capable of Direct Connect, but they do require 64-bit connection libraries.
    – Vince
    Mar 12, 2014 at 15:01

1 Answer 1

2

Yes, ArcSDE 10.x can read SDEX export files written by previous releases, however:

  1. You need a client compatible with the server
  2. You need either an application server service or a correct 64-bit Direct Connect client environment
  3. You need network connectivity from the host with ArcSDE tools to the geodatabase server (either on the application server port, or on the Direct Connect database's port, as appropriate)
  4. You need to understand that SDEX export files are not geodatabase-aware, so functionality like feature datasets, domains, and subtypes, and even annotation will not pass safely through this format

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.