2

I am trying to publish a map on my server but I am getting this error:

Compressing the service definition failed.

I have changed the location of service points, still the Error remains.

How can I solve this issue?

3 Answers 3

5

Make sure you are running a 32bit version of Python - I ran into this error a while back and I was using 64bit Python and it caused this exact same error - this may solve this for you :)

1
  • 5 Years and at least 3 versions later this is still a workaround. JFC, ESRI. Thanks for the suggestion @Vidar
    – psl
    Commented Jun 9, 2020 at 20:06
0

001269 : Compressing the service definition failed documentation suggests that you should:

Make sure you are not accessing files in the folder containing the service definition.

2
  • How can I not access the files when I need to add them to the map?
    – KDot1254
    Commented Mar 9, 2014 at 0:29
  • 1
    @KDot1254 I am guessing that the process that is adding them to the map requires exclusive access and you may have another process e.g. ArcMap, ArcCatalog, Windows Explorer, IDLE, etc accessing one or more of the necessary files
    – PolyGeo
    Commented Mar 9, 2014 at 1:11
0

This same issue occurs for me if I am using a 64 bit Python version. I believe by default ArcMap/Catalog will use 64 bit Python for geoprocessing (if installed). To fix this I wrote the necessary steps in a python script and ran it in a 32 bit version of Python. In my case, I open a 32 bit Shell that should say something like [MSC v.1500 32 bit (Intel)] on win32. Then I open the script from this same Shell and run it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.