1

I have a GEOTIFF in QGIS that shows values of 0 and 1 and I want the 0 values to have no fill so that background vector layers can show through and so I can easily overlay things in a print composer for final production of the map. This is an easy task in ArcMap but doesn't seem to be possible with QGIS raster layers because they require you to have a color ramp/a color for each class when you change styles. How do I get this to work? Having 0 values be white isn't good enough for what I am mapping.

2

You can control the transparency on raster layers in the Transparency tab in Layer Properties. Just go to the tab, and click the green plus sign to add a new option to the Transparent pixel list. You can set the min and max range values, and then set the transparency percentage for that range.

You could also try setting the "Additional no data value" to zero. I think that would work. I didn't have a geotiff with a range of 0 to 1 to test it though.This image shows a DEM on top of a vector layer with a range of transparent values.

  • thanks @midfield99, this worked well. I just set min and max values of 0 to 100 percent transparent. – user25902 Mar 11 '14 at 0:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.