3

I need my "units" set in AutoCAD to reflect a "compass". I need the bearings I enter to reflect a complete circle with North being 0/360d, East being 90d, South being 180d and west being 270d (as shown in the attachment). I have never had to set my units up this way in CAD. I've always used the survey plan type bearings (ie - N 90d 10' 2" E). I just can't seem to figure out how to set my units properly.

enter image description here

3
  • I see that you have precision set to 0. You should use at least mins " for the call in your question. to set what you are asking about you select the direction button below. and set the north angle.
    – Brad Nesom
    Commented Apr 25, 2011 at 18:22
  • Hey Brad -- The print screen is actually arbitrary. It is not a reflection of the settings I have chosen. I just opened a default CAD drawing to use for the image I attached. I think I'm getting close here. Suggestions still welcome however!!
    – Dano
    Commented Apr 25, 2011 at 18:29
  • Try setting ANGBASE system variable to 90 and ANGDIR to 1, maybe that will help. Commented Apr 25, 2011 at 18:41

3 Answers 3

2

That (screenshot) is where you need to make the changes. Set it to degrees for angle and set your precision to second or decimal seconds depending on your calls, e.g. 90d45'36.05".
Select whether you want clockwise or counter with the checkbox in your screenshot.
Then in the direction you set the north direction.

As described here on dotsoft.com...

How do I enter boundaries in bearing & distance?

First you need to set the appropriate units in the DDUNITS command. Set the angular units to 'Surveyor', then choose the direction button and make sure that 'Angle Direction' = east, 'Rotation' = counter clockwise. Even though you have set to Surveyors Units it won't work right unless set this way.

Then using the LINE or PLINE command you enter the calls as relative polar coordinates.

  • Command: LINE
  • Start Point: (Pick One)
  • Next Point: type @123.45 < N45D30'15"E
  • Next Point: type @234.56 < S25D10'10"W

Notice the syntax for the relative polar coordinate. You put the @ sign first, which means relative to the last point. Next comes the distance. Last is the bearing. Its enclosed in the quadrant NE, NW, SE, SW, note the use of letter D to indicate the degrees.

8
  • There seems to be some corruption of the text: perhaps `90d45'36.05"' belongs in the command example?
    – whuber
    Commented Apr 25, 2011 at 20:40
  • I gave you a check Brad. Most of this answer is actually "exactly" what I've done. I did adjust the precision, and as you said, I set the direction to North (and toggled "clockwise"). The settings seem to have worked. If I wanted to go due west at 50 metres, I just typed @50<270 and it worked. I couldn't get CAD to treat the circle as a 360 degree animal!! It wanted to break it in to halves (east & west). I'm just drafting in a fresh drawing, and I'll copy/paste everything over once it's all in place.
    – Dano
    Commented Apr 25, 2011 at 20:46
  • @whuber - that just refers to the angle at which I want the line drawn. In Brads example, my line would be drawn at an angle of 90 degrees, 45 minutes and 36.05 seconds relative to the starting point of the polyline. What starts to get crazy in CAD, is getting that directionality set properly!!! Well .... for me anyway!!!
    – Dano
    Commented Apr 25, 2011 at 20:57
  • @Dano But the command example does not follow the syntax @Brad described and the "90d....05" text is completely out of place. It looks like part of the answer got translocated to an unintended location or maybe even worse stuff happened (which is why I'm asking about this in a comment rather than attempting an edit).
    – whuber
    Commented Apr 25, 2011 at 21:02
  • I see what you mean now. It almost looks like an accidental copy/paste to me ... as though he was editing and accidentally pasted it there without realizing. Yes .... it looks as though it should follow the "@123.45". There should be a "<" in the middle too. I understand what you meant now ... sorry. :o)
    – Dano
    Commented Apr 25, 2011 at 21:09
0

try

Menu>Format>Units

command line: units

http://docs.autodesk.com/ACD/2010/ENU/AutoCAD%202010%20User%20Documentation/index.html? url=WS1a9193826455f5ffa23ce210c4a30acaf-527c.htm,topicNumber=d0e328054

Base Angle Sets the direction of the zero angle. The following options affect the entry of angles, the display format, and the entry of polar, cylindrical, and spherical coordinates.

East Specifies the compass direction east (the default).

North Specifies the compass direction north.

West Specifies the compass direction west.

South Specifies the compass direction south.

Other Specifies a direction different from the points of the compass.

Angle Specifies a value for the zero angle when Other is selected. You can specify the angle by entering a value.

Pick an Angle Button Defines the zero angle in the graphics area based on the angle of an imaginary line that connects any two points you specify with the pointing device. Available only when Other is selected.

0

1. Check Units Setting

First check that your settings are correct by typing DDUNITS, adjusting to your liking, and also hitting the Direction... button to ensure this is set to North.

2. Type < When Entering a Bearing

Then (and I found this quite confusing at first), in order to enter bearings from north you don't hit tab and enter them in the box shown here:

enter image description here

Instead you need to type the < character and then the bearing, so it looks like this:

enter image description here

You can enter the distance first or the bearing first, I don't think it matters, as long as you type the < before the bearing.

Couldn't find that clearly explained in the manual anywhere. Crazy.

3. DYNMODE Setting

I later discovered that you can type DYNMODE 1 in the AutoCAD command line and it will then show the correct bearing from north when you're drawing lines, not the angle from east.

According to AutoCAD this disables the "Dynamic Dimensional Input" feature, which is actually just getting in the way.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.