0

I'm wondering if anyone can help me. I added a CSV file on ArcGIS 10.2.1, I displayed the coordinates and everything worked fine. However, when I duplicated and edited the new CSV file to change the numbers in one column it's not working. Instead of my XY columns I keep getting the choice of lots of fields instead. Does anyone know how to fix this? It has been an intermittent problem through my project. enter image description here

Thanks for your reply. I'm editing the file in Excel and saving as to create a new file. I then restart ArcMap and add the file but the same error happens. Any ideas? The original file still works as normal.

The names of the columns are ID, X, Y, OFFSETA, OFFSETB, RADIUS2. The headings don't change with the new files I create, just the figures in one of the columns.

  • What does the header record or Column names look like? It seems ArMap is not recognizing the first record if the fields are named Field1, Field2,etc. – klewis Mar 13 '14 at 19:54
3

If you are changing the CSV in another program and ArcMap isn't recognizing the new file, restart ArcMap. ArcMap seems to hold the file in-memory, even when the file is removed from the table-of-contents.

2

Another thing to check is the schema.ini file which Arc creates in the directory where your .csv file is located. This file contains information about the fields in your .csv file and how each field should be interpreted (e.g. string, float, integer). After editing your .csv file, you may need to check the schema.ini file to make sure Arc is interpreting the fields correctly.enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.