I am trying to open a pdf using QGIS action tool with Adobe Reader. Currently, the action defaults to Internet Explorer which doesn't succeed in opening my document. I'm currently able to open AutoCAD files and photos. Does anyone know how to set the default software used to by QGIS actions? I'm using QGIS version 2.0.

my pathname in the attribute field is: explorer C:\Documents and Settings\user\Bureau\file.pdf

Action Type: Windows. Name: Open file. Action: [%"pathname"%]. I didn't click the Capture checkbox.

Thanks in advance!

  • Does it work if you remove "explorer" from the attribute field? – underdark Mar 15 '14 at 9:29
  • No, i get a dialog box saying "unable to run command" – user25976 Mar 18 '14 at 18:29

While i'm still not able to set a default browser, I've succeeded in directing it to the file's default browser (under file properties) by entering the pathname as: cmd /c "fullpathname"

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.