I have an attribute table with three columns "FID" "Shape" and "Class"

All records have the same shape (polygon). Each record has its own FID. I have three classes, "A", "B", or "C". I have twenty records for Class C and would like to combine them into one record.

I have tried doing a dissolve without specifying anything in the Dissolve Fields area and the result was a shapefile with all the Classes combined into one, which I don't want. I also tried doing a dissolve while specifying Class in the Dissolve Fields area. This resulted in a shapefile with the same twenty records for Class C.

How do I get those twenty polygons into one record?


3 Answers 3


If you want to combine same records with same value in Attributes Table:

  1. start editing
  2. select records you are going to combine with together
  3. Merge selected records (You can find merge in start editing menu)

you can get more information from this link: Merging features in the same layer


Use the dissolve tool and dissolve based on field containing your classes. This will result in three multi polygons A B and C.

  • 1
    I gave this a try, unfortunately I still have those twenty records for Class C. For some reason it refuses to dissolve them.
    – user26142
    Commented Mar 17, 2014 at 16:47
  • 1
    @user26142 You need to make sure the "Create multipart features" checkbox is checked, as well. If that doesn't work, then I would bet that the values in the Class field are not identical to each other -- perhaps some have a trailing space character and others don't, etc.
    – nmpeterson
    Commented Mar 17, 2014 at 16:58
  • The "Create multipart features" is checked, still not working. That's okay, Halil Siddique figured it out (see above). Thank you for helping!
    – user26142
    Commented Mar 17, 2014 at 17:10

You can use the dissolve tool, but you need to provide an attribute to dissolve them on. Based on your example, you would dissolve on the different classes. This would put all the same classes into a single row, resulting in a multipart polygon.

  • I did a dissolve on the Classes, hwoever I still have twenty records for Class C. For some reason it is refusing to dissolve those.
    – user26142
    Commented Mar 17, 2014 at 16:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.