I can't get my maps to work because of an issue I'm having with my CSV files. I'm trying to import coordinates and heights of wind turbines, and radius for a viewshed analysis and it works on the original file but whenever I edit the file at all, such as changing the radius column figures from 30000m to 5000m and try and display my XY coordinates in the new file, ArcMap 10.2.1 isn't recognising my columns and instead gives me the option of lots of 'fields' to use instead. It starts from 'field 7' so I've worked out that it's not recognising my text but I have no idea why, especially when I haven't changed my text from what it is in the original file which works fine! Can anyone help me out?

  • 1
    Can you provide the header row from your CSV? Several things could be wrong, and this would make it easier to track down. And what are you using to edit? Excel or a text editor like notepad++ or sublime? Mar 17, 2014 at 17:51
  • Hi, thanks for your fast reply! My header row is "ID, X, Y, OFFSETA, OFFSETB, RADIUS2" I'm using Excel to edit my file. I could email a copy of the Excel file if it would be easier! Thanks again for the quick reply, I'm starting to panic now lol
    – Ross
    Mar 17, 2014 at 17:56
  • Have you tried just saving your CSV's as excel files and importing those in? I know older versions of ArcMap had problems with them but newer ones (10 and later) seem to be better. You could also try saving your CSV with a different program like Open Office Calc which you can download for free from here link. Lastly make sure the file path for where your files are located is short, this is normally more for rasters but I know sometimes issues occur. So basically place your files at C:\Stuff, not C:\Stuff\Cool Stuff\March Stuff\SuperDooper... etc Mar 17, 2014 at 18:12
  • 1
    Thanks for your answer! I've tried pretty much every format available to no avail. I have been saving my files onto a memory stick so its D:\here. I'll give another program a go and hope I have some luck! Thanks again for your reply I'll let you know if it works.
    – Ross
    Mar 17, 2014 at 18:22
  • Have you visually compared the original file with one edited in Excel? Mar 17, 2014 at 18:34

1 Answer 1


Have you tried converting your csv table to a txt file instead? I have trouble with the csv format on occasion even in 10.2 so I always start first with a txt file, if possible. As for why it happens, I am not sure.

  • I tried CSV table also same issues will come.- MapHound Jul 6, 2017 at 11:10
  • 1
    This worked perfectly. I simply renamed the .csv file extension to .txt and ArcMap imported it fine. Thanks
    – mkmitchell
    Feb 28, 2018 at 18:07

Not the answer you're looking for? Browse other questions tagged or ask your own question.