3

I have the road graph plugin installed, but when I try to configure it with the Settings dialogue, no layer names appear in the Layers field. I have tried various shapefiles, but the Settings dialogue doesn't see any of them. Anyone else seen this ? Thanks.


Addition: I am having the same problem. A few more details regarding my experience of the issue, since not too many are provided above:

-Road Graph plugin version 0.1 with QGIS 2.2.0 32-bit via OSGeo4W install on a 64-bit Windows 7 machine. Tried same software versions on another Win7-64 machine (thinking maybe some setting was tweaked wrong). No difference. I have tried shapefile and spatialite line layers of topologically sound street networks. Tried having just one layer at a time loaded as well as multiple, with no change. Made sure CRS for layer and project were matched and that 'on the fly projection' was disabled. Also de/re activated plugin.

Under Vector>Road Graph>Settings all 3 dropdown menus under the Transportation Layer tab are grayed out/inaccessible with no options shown. All other settings in this dialogue are accessible.

Clicking on the canvas to choose Start and Stop points registers coordinates and shows selected points on the canvas. When 'Calculate' is attempted, "Plugin isn't configured" error (not surprising since layer couldn't be chosen).

2

This appears to be a bug with 2.2

I tried with 2.2 and reproduced your errors.

Then tried it with 2.4 with no errors.

protected by Community Mar 21 '14 at 0:41

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.