1

I want to connect to a PostGIS table Using MS Access.

The table has been created using the PostGIS Shapefile loader in pgAdmin. It has been encoded at LATIN1 (it wouldn't load with UTF-8 default).

I have installed the ODBC driver from: http://www.postgresql.org/ftp/odbc/versions/msi/ (09_03_210)

I have set up the link in MS Access (using "PostgreSQL Unicode" driver), and I can bring the table in. However in all of the fields it is displaying #Error rather than the data.

I don't get this error with a table loaded with UTF-8.

I'm not sure where to set the encoding variable to LATIN1 when I call the data. I have tried doing so in the "Data Source" Advanced options under "Connect Settings"

SET client_encoding TO LATIN1

but it hasn't helped.

Is there another problem here - am I setting the encoding variable in the wrong place?

Any help appreciated.

1

It's counter intuitive, but I'd try using the PostgreSQL ANSI driver even for reading UTF-8 database. It often works where the Unicode one fails. Though in theory Access 2010 should not have this problem.

Have you verified that the data looks okay via pgAdmin. It's possible the encoding of the file was not LATIN1 and might be win1252 or something else.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.