1

I am using QGis version 2.2.0 and I set the snapping option to the vertex, with a tolerance of 1.5 meter. When I draw a new polygon next to an old one, it seems like the vertices are automatically anchored to each other, but actually when I zoom in to a scale of, let's say, 50:1, I can clearly see that the two vertices have not been anchored. Instead of one single vertex, I have then two of them.

It's very annoying because this automatic error can create topological problems of overlapping and gaps among polygons. In fact I detect these problems when I use the topology checker.

Did you encounter the same issue? How can I avoid it?

Thanks

  • 1
    I rarely use the snapping settings in meters--I find that pixels makes more sense. If you measure your small differences, are they less than 1.5 meters, or greater? – Darren Cope Mar 20 '14 at 12:56
  • The differences are way less than 1.5 meters. The gap between the old vertex and the new/bad positioned vertex is about millimeters. – user28279 Mar 20 '14 at 14:17
1

Try setting the tolerance to 10 pixels and the snapping option to vertex and segment. I never had a problem with these settings.

  • I tried with the 10 pixel tolerance with vertex and segment, but it makes the same type of error[1] [1]: i.stack.imgur.com/ZTRY3.jpg Other suggestions? Thanks – user28279 Mar 20 '14 at 14:18
  • Did you use the node tool to drag the "wrong" vertex to the old one? – qgs Mar 20 '14 at 14:35
  • As per most of suggestions i am also using snapping tolerance as in pixel say 8 or 10 px. But i want to be sure that 1px tolerance is equla to how much meter tolerance if my layer has projection srid = 4326....Can i get some light on this... – Rajesh Kumar Sep 19 '16 at 6:46
1

I suggest to update qgis (first of all) at least at 2.4 version.

Scale of 50:1 is a non sense... its bigger than reality. Topology have a tollerance so I don't think this could be a problem for you. Can you measure the distance of the two points? how much is it?

For being sure that the two vertex are snapped (in qgis), just anable the topologycal editing and then move the vertex. If the 2 vertex move at the same time they are snapped.

If you have problems you can import the layer in grass and use the snapping option whit a small tollerance (1 meter for example) and, after that, export again the layer. So you are sure that the vertex are snapped.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.