1

I'm using the MMQGis plugin to "Join Attributes From CSV" into a shapefile and am having trouble getting QGIS to interpret some numbers as numbers (rather than strings which is what its doing).

This is becoming a real problem because the values do not behave like they should when trying to order them, select above a range, etc.

I've seen two somewhat similar questions to this but the answer to this question instructs the user to import the CSV as a layer. But the CSV data I'm trying to import is not geocoded and I'm using values (things like zip code, etc) to join in the CSVs, so I don't think that question's answers might help here.

3
  • The CSV data does not have to contain coordinates. You can load it using Add delimited text layer if you tick the "no geometries" option.
    – underdark
    Mar 20, 2014 at 18:53
  • You're right. Should I close this? Mar 20, 2014 at 19:42
  • You can mark your answer as an answer after the question is a day old. I think that should work.
    – midfield99
    Mar 20, 2014 at 19:47

1 Answer 1

1

Once the CSV has been joined to the Shapefile, use MMQGis > Modify > Text to Float to convert the appropriate columns

Not the answer you're looking for? Browse other questions tagged or ask your own question.