1

I am using GeoServer 2.4.5 with built-in GeoWebCache 1.5.0.

I'm integrating GeoServer with a Google Maps V3 api frontend, and I got it to work reasonably well using the WMS service. However, I noticed that there's a builtin 'gmaps' service, as described here: http://geowebcache.org/docs/1.5.0/services/gmaps.html

I've tried to use it, with a url like:

http://myserver:8080/geoserver/ok/gwc/service/gmaps?layers=ok:OK_Twp&zoom=9&x=114&y=200&format=image/png

however, I get the following response:

This XML file does not appear to have any style information associated with it. The document tree is shown below.
<ows:ExceptionReport xmlns:ows="http://www.opengis.net/ows" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" version="1.0.0"     xsi:schemaLocation="http://www.opengis.net/ows http://myserver:8080/geoserver/schemas/ows/1.0.0/owsExceptionReport.xsd">
<ows:Exception exceptionCode="InvalidParameterValue" locator="service">
<ows:ExceptionText>No service: ( gmaps )</ows:ExceptionText>
</ows:Exception>
</ows:ExceptionReport>

For some reason, it can't find the 'gmaps' service. Any ideas? I've made sure to enable "Global Services", but can't find any configuration regarding the gmap service in the GeoServer web interfact.

2

At a quick glance it looks like an issue with the base URL. Try removing the workspace name in your url(it's included in the layer name anyway) so that your URL is:

http://myserver:8080/geoserver/gwc/service/gmaps?layers=ok:OK_Twp&zoom=9&x=114&y=200&format=image/png

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.