1

haven't tried the stackexchange page before, but since I can't find information on this problem: I can't completely uninstall QGIS, I want to do a complete, clean reinstall, but whenever I start the installer after having uninstalled QGIS it shows:

QGIS Dufour or QGIS Valmiera already installed

So it seems the uninstall doesn't work properly.

I'm working on a Fujitsu Esprimo with an Intel(R) Core(TM) i7-4770 CPU @ 3.40GHz (8 CPUs), ~3.4GHz, 32768MB RAM, Windows 7 Enterprise 64-bit (6.1, Build 7601) Service Pack 1.

I've recently tried installing OSGEO4W in addition to QGIS. Can this be the problem? Another thing that kept happening with all my QGIS installation from 2.0 upwards (I have only the newest one installed currently, 2.2 Valmiera) is crashes at exit ("QGIS.bin has stopped working). I'm having no other problems with it though.

Could you give me instructions on how to completely remove the program and do a clean reinstall? Thanks in advance!

0

I found that by removing the reg key "HKEY_LOCAL_MACHINE\SOFTWARE\QGIS Valmiera". You can then reinstall the 64bit version.

  • 1
    Before doing this, remember to backup the registry! – Paul Jun 30 '14 at 13:42
3

If you want to completely remove QGIS:

  • Start -> Control Panel -> Programs and Functions to uninstall the software
  • Delete the remaining installed folder under

    C:\Programs\ (for Standalone 64bit), C:\Programs (86)\ (for Standalone 32bit), C:\OSGe04W or C:\OSGeo4W64

  • Remove the .qgis2 path from your C:\user\... folder

  • start regedit, search and remove all entries containing QGIS

... and try the 32bit version, it has fewer installation bugs.

-2

QGIS Dufour or QGIS Valmiera already installed Start -> Control Panel -> Programs and Functions

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • The solution suggested above by dbarkey works, I can confirm this. You need to delete the registry key he specified after deinstallation of the program. Somehow this error occurs only in the 64bit version, it doesn't occur in 32bit QGIS. It's still present in QGIS Chugiak (2.4.0), haven't tried the newest one (2.6.0 "Brighton") yet. – Lordon Nov 11 '14 at 13:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.