0

In my QGIS project I have added a WMS layer for which the CRS is WGS84 EPSG:4326.

Now I want to show my shapefile layer which has the same CRS.

QGIS shows the layer separately but does not show with the above WMS layer.

Can any one help me to understand why?

I am using Quantum GIS 1.7.0

I made up shapefile for my project for a city area in which point locations are there with some attribute data.

I have directly drag and drop shapefile in QGIS. is it OK or I made some wrong thing?

please guide me..

2
  • 1
    Welcome to GIS.SE. Can you expand on your question (just click edit below the question) with some more details. For example, which QGIS version do you have? How did you load the ShapeFile? What layer order do you have set?
    – BradHards
    Mar 22, 2014 at 7:28
  • 1
    Can you share your shapefile and/or the link to the WMS? It's quite uncommon to have WMS in EPSG:4326. There are many potential reasons why you might have problems. How did you create the Shapefile (especially considering the CRS)?
    – underdark
    Mar 22, 2014 at 9:19

1 Answer 1

1

I've followed carefully your steps and I think that, if you want to see both layers in the same time, not separatelly, you need to make an additional first step: to go to the project properties and to enable the on-the-fly CRS transformation.

enter image description here

enter image description here

Only after this step is completed you can properly add and see together your wms and shapefile layers, otherwise you will not see the wms layer (tested on QGIS 1.7.4, 1.8.0, 2.0.1 and 2.2.0):

enter image description here

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.