1

I have Created a spatial ETL tool to do small operations like adding an ID, updating different fields, etc.

While running it from the Edit Session of Spatial ETL it runs well and good.

http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#//00210000003q000000

Now I want to run it from ArcCatalog without opening the tool, but it is throwing an error

enter image description here

and inside geoprocessing results it Shows

ERROR 000819: THE TOOL IS NOT ASSIGNED

can anyone please help me with this, on how to run the tool without using the edit session.

One more question: Inside the properties of the tool, "Always run in Foreground" option is disabled, because of this I guess I have to disable background processing and run the tool in foreground. The help page " Foreground and background processing" is also not solving the problem. enter image description here

1

Try importing the toolbox to catalog before running it from the same instance in ArcMap maybe. http://help.arcgis.com/EN/arcgisdesktop/10.0/help/index.html#//00vp00000013000819.htm

  • my tools are already in ArcCatlog inside the MyToolboxes Folder, and we want it to run directly from ArcCatlog, without programming, i have added new image in the question, please see that. – Mayur Sharma Mar 24 '14 at 5:21
  • It worked, what i did is from ArcCatlog i opened ArcToolbox, there an option is present of adding a toolbox, select that, and browse to the path where the toolbox is present. After this the toolbox is added into the ArcToolbox, from where it executes properly. The Importing Toolbox helped me do that thank you @geoffreyWest – Mayur Sharma Mar 24 '14 at 6:23
0

This can also happen when 64bit background processing is installed (up to at least ArcGIS 10.3.1) and a 64bit "third-party Python module referenced in the toolbox is not installed ... When the Python toolbox tool is run, 64-bit background geoprocessing cannot access the module in the 32-bit Python folder. The toolbox appears to be valid with correct syntax because ArcGIS has access to the 32-bit modules, but does not check for the 64-bit modules."

Solutions are:

  • uninstall 64bit background processing
  • identify the missing module and install it's 64bit version (if available)
  • Edit the Python toolbox's tools so they always run in the foreground by assigning the self.canRunInBackground line of code with False:

    class Tool(object):
        def __init__(self):
            """Define the tool (tool name is the name of the class)."""
            self.label = "Tool"
            self.description = ""
            self.canRunInBackground = False
    

From Esri-KB 40933: http://support.esri.com/cn/knowledgebase/techarticles/detail/40933. I couldn't find a current 10.3x version, not sure why.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.