-1

This question already has an answer here:

I have fields in my datasets such as HR60, HR70, HR80, HR90

When I tried to use field calculator using the following [HR70]/[HR60], all I got was 1, 2, 3, 4 as my values.

Last time I checked 1.14/2.24 is not 1 and 2.92/.69 is not 4.

In a map I did using field calculator using [ ]/[ ]*100 to get percentages and it let me do that so why this time am I getting whole #'s and not the appropriate decimals?

marked as duplicate by PolyGeo, Fezter, Devdatta Tengshe, Jason Scheirer, BradHards Mar 24 '14 at 6:48

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • I am using ArcMAp 10.1. – user28383 Mar 23 '14 at 21:14
  • 3
    Your output field might not be set as a double. – Paul Mar 23 '14 at 21:17
  • @user28383 Can you edit your data type (shapefile, file geodatabase, etc) into your original Question, please? And also, include what the data type of the field you are trying to set this ratio to, and the parser you are using. – PolyGeo Mar 23 '14 at 22:43
  • Well, my field preferences are set rounding to 2 decimal places. – user28383 Mar 23 '14 at 22:55
  • This is a shapefile. – user28383 Mar 23 '14 at 22:55
1
  1. I suspect the field you are calculating is in short or long integer format and thus will not be able to store decimals. Check the field type by

    right-clicking the field name > Properties... > type:

    You need to add a new field as either float, double or text and redo the field calculation.

  2. Another thing to check is if your field has rounding preferences saved. You can check this by

    right-clicking on the field name > Properties... > Field Properties > Numeric... > Rounding.

Not the answer you're looking for? Browse other questions tagged or ask your own question.