2

I am using ArcInfo desktop 10.2.1, with an admin connection to ArcGIS for Server Standard 10.2.1

I have used the "Create Map Server Cache" tool in ArcToolbox to prepare all the underlying structure for the cache of an existing un-cached basemap service.

I've used a predefined tiling scheme, which tells it to generate cache tiles at 3 scales - 1:8000, 1:5000, 1:2000.

I've set the tile cache format the "PNG" and the Storage format to "Compact".

This tool runs without any problems.

The problem comes when I come to actually generate the cache using the "Manage Map Server Cache Tiles" tool from the toolbox.

Only 2 of my 3 scales are visible in the "Scales" box.

enter image description here

In Catalog, if I right click on my service > Service Properties > Caching, the slider shows the full extent of the 3 scales I want to cache at.

enter image description here

If I click on the Advanced Settings tab, I can see the 3 scales, however one of them is greyed out. This is the one that's missing from the "Managae Map Server Cache Tiles" tool.

enter image description here

Is this a bug in the software? Or is there something I have missed? I've also tried it with ArcInfo 10.1 and I get the same problem.

Is there a limit to the number of tiles a single cache scale can hold? Or a size limit?

If this is a bug, is there a workaround?

  • Check the cache directory on the server to see if it's created 3 folders for the 3 scales. – Mintx Mar 25 '14 at 21:45
  • There are only 2 folders. – Dan_h_b Mar 26 '14 at 7:53
  • In the cache directory, there should be a file called conf.xml - check that file to see if all three layers are listed in the LOD category. Usually when a layer is greyed out like that, you've opted to not cache that scale somewhere. – Mintx Mar 27 '14 at 16:10
  • Also in the Advanced Settings screen from your last screenshot, there should be Minimum cached scale and Maximum cached scale right below where you cropped the image. Be sure 2000 is included in the Maximum cached scale dropdown. – Mintx Mar 27 '14 at 16:13
1

As @Mintx suggested in comments I would gess as well that this can be done by the setting of the Min and Max cache scale on Advanced Caching Properties. Once I solved similar problem with this setting.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.