1

I am migrating one of the existing project (custom Geo-processing tool- class library project) source code which runs on ArcGIS 10 SP4 and Visual studio 2010. This is working fine. I am could run the project and able to add this tool in ArcTool box. Publish this as GP service and consumed in application.

I am moving this code to new machine which Windows 2012 server and ArcGIS 10.2 and Visual studio 2012. The source code is fetched from TFS and and code is built successfully after updating ArcGIS libraries to 10.2 When I run the project in VS2012 - class library (starting - ArcMap.exe with specific mxd document as input) break points are not hit.

After doing some research I have found that ESRI Link here I have to update ArcMap.exe.config file. After updating config file to use Framework 4.0 break points are set but not getting hit. Whenever I run the class library project MXD is opens, but the break points are not getting hit and not able to debug the code. Project properties in VS2012 is same as I used in VS2010 (checked Register COM Exception) and enabled debugging.

Question: a) Why VS2012 is not hitting breaking points? b) Dll is successfully built, but I am not seeing this custom tool box in "Add tool " box in ArcTool box.

I am not sure what am missing or some changes in ArcGIS 10.2. Please help.

1

Why VS2012 is not hitting break points ?

a) I ran ArcGIS code Migration Analyzer from Tools Menu in Visual studio 2012. This pointed list of issues like some dll like ESRI.ArcGIS.Geoprocessing specific version set to false.

b) Project build property set to "Any CPU"

Why tool is not added to tool box

a)Need to explicitly register the dll by right click and select "Desktop".

Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.