I'm fairly new to geocoding in ArcGIS and stumbled upon first problem.

I'm working with GeoPost data from Swiss Post. As long as I'm using their default locator everything works flawlessly.

I also received additional table with alternative street names (French <-> German) that I can link to main data by unique street ID. They exist for small subset of main dataset. However, there is no way to add alternative street names using the Swiss Post locator.

I browsed through ESRI's docs but it didn't help much in this case.

I've tried building two separate locators (one with German names, one with French) and wanted to combine them into composite locator. Unfortunately I get general error message without any further pointers :/

Is there a way I could use this additional data to build composite address locator that will use both language versions of street names? Is there any other potential solution?

1 Answer 1


Have done a European Address Geocoding Table Locator (24 languages)

We created Alternative Names (Alt_Name_EN Alt_Name_FR Alt_Name_GER etc) (only Greek was an issue http://en.wikipedia.org/wiki/Greek_alphabet requires UTF-16)

but in the the same locator with many joins.


Key part for it to work is Primary Table:Altname JoinID

  • Thanks Mapperz. I was thinking about using this option as well. However using locator that came with original data I only have 'Primary data' and 'Alias table' as options for the role. 'Alternate Name' is mysteriously missing.
    – user173
    Commented Apr 28, 2011 at 14:15
  • 1
    suggestion create/add Alternative Names Field (just to test a 10 or so). See how well it matches.
    – Mapperz
    Commented Apr 28, 2011 at 14:26
  • Using provided style of the locator I cannot add/modify fields. Shall I manually change '.lot' file to do that?
    – user173
    Commented Apr 28, 2011 at 14:35
  • 1
    we copied and then edited (customises) in xml a standard locator help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#//…
    – Mapperz
    Commented Apr 28, 2011 at 14:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.