0

I'm working with qgis v. 2.0.1. I have some data points and I just wanted to create a new shapefile with line geometry. In the new vectorlayer-window, I added some attributes (approx. 10) and klicked ok but it didn't create a shapefile (nothing happened). I tried again without adding any attributes and it worked. Why is there a problem when I want to add some attributes? Of course I could add attributes with the Table Manager or manually in the attribute table but I'm just wondering why it's not working this way. Thanks.

  • Are you sure you have enterd the right data types for the attribute fields, e.g. string when text is expected? – AndreJ Mar 26 '14 at 8:36
  • I can't recreate the problem. Also, in your subject you say you want to create a line shapefile but in the body of the question you say you want to add some points, so there is a little confusion as to what you are doing. – MappaGnosis Mar 26 '14 at 8:39
  • @Andre Joost: Yes I think I did this right. And it shouldn't be a problem because there aren't yet any values in the shapefile, I just set the columns. – qgs Mar 26 '14 at 8:56
  • @MappaGnosis: I already have some points and I want to add a line layer to the map. So actually the points are not that important. Sorry for the confusion. – qgs Mar 26 '14 at 8:57
  • You know about the restrictions on column names for shapefiles? Max 10 characters, avoid non-ASCII-charcters, no number at the first position. – AndreJ Mar 26 '14 at 9:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.