4

I've no clue how to solve this issue in the exercise that I'm trying to perform.

The point where I'm stuck is 4. "Create signature file as LandsatCompS.sgs". I've done what it says in the exercise. I got a error message "Failed to create signature file.

The aim of the exercise is to carry out a supervised image classification of the Northern half of Jutland.

  1. Start ArcMap and add the Landsat images from the B series (summer images).
  2. Create a composite image composite image for all bands except band 6 – the thermal band. Save the image as LandsatCompS (S for summer).
  3. Open the orthophotos for land (not urban). Add eventually more orthophotos from the Geodata library. Try to identify the necessary number of different land cover classes to cover all areas on the orthophotos. Not more than 15!
  4. Open the Image Classification window, and start digitising training areas. Two for each class. Create the signature file as LandsatCompS.gsg.
  5. Carry out maximum likelihood classification using LandsatCompS as input raster and LandsatCompS.gsg as signature file. Output is ML_class_NJ1. Use default values for the other inputs.
  6. Put the right colours on the new map and compare with the orthophoto and other maps available for Northern Jutland.
  7. Where are the problems? Try to make an improved classification by increase the number of classes and digitise new training areas. Carry out the classification and assess the result. Which one is best?

Classes

Error message

Landsat Image

Training samples

enter image description here

  • 1
    can you show your training sample on a map on top of the Landsat image ? You have a very large number of pixels, this is surprising for training samples on Landsat (and probably not necessary). – radouxju Mar 26 '14 at 11:23
  • @radouxju I've tried to show the training sample on a map on top of the Landsat image, however I couldn't (I'm bit new). Instead I provide two screenshot, at full extent. At the same time I will try to perfrom the exercise by obtaining less pixels. – Enriue Mar 26 '14 at 12:07
  • by picking less pixels I managed to create the file @radouxju – Enriue Mar 26 '14 at 12:47
  • 1
    @Enriue Consider providing a solution to your question so that this can be considered resolved. Thanks. – Aaron Mar 26 '14 at 13:04
  • The solution was to catch less pixels as it can be seen in the first and last screen shots. By doing this the tool manage to create the signature file. – Enriue Mar 26 '14 at 13:09
3

I had some success by changing the target directory to which I saved the signature file. Rather than using the server space I had been alloted, I chose the local desktop, and it worked without a hitch. Not sure why.

2

As a general rule-of-thumb, if training data are being extracted from n bands, then >10 n pixels of training data are required for each class (Jensen, 2008). This allows for proper calculation of the variance-covariance matrices used in some classification algorithms.

ArcGIS often has problems creating a signature file with too many pixels. Your pixel count exceeds 200k in some of the classes, which is very large. The solution is to reduce the number of pixels in your training sample manager following the recommended pixel guidelines.

Reference

Jensen, J. R. (2005). Introductory digital image processing: a remote sensing perspective (No. Ed. 3). Prentice-Hall Inc..

1

I just had this same problem and stumbled upon your answer, and resolved it a different way:

Make sure that the Image you used to create samples (polygons), is selected in the drop down list when you try to create the signature file.

I see for your Pics you have LandSatCompS selected for all images except the one with the error, where you have a different image.

In my case, I was trying to create a signature, but there was no image pixels in the location of the sample polygons!

1

I had the same problem. I note previous people changed folders and it worked.

I had a folder name with a space in it. I changed the space to an underscore and it worked. I think this is the root cause.

I never usually use spaces in folder names, and would suggest that standard to others.

NOTE: Changing the folder name may affect other parts of your map if you have used it elsewhere. I then also had to fix some layers with set datasource.

1

To solve this problem I removed spaces and special characters from the path when saving the file and it worked.

0

I had the same problem and was able to solve it by:

  • Creating the signature file in another directory as others suggested.
  • Saving the training data as a shapefile, Restarting ArcMap and trying again.
-2

Try to change the output directory. I had the same problem. Simply save it to the Desktop. ArcMap has issues in saving if the saving path is too long.

protected by PolyGeo Oct 26 '18 at 8:04

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.