1

I am working on a project that is modeling runoff at a county level. The DEM used is lidar derived and has a 5 ft resolution. The general workflow I am flowing is

  1. Sink evaluation
  2. Sink Selection (to give a minimum drainage area)
  3. Fill sinks (using the deranged polygon from the sink evaluation and the 'Use IsSink field' option).

When I run the fill sinks tool I receive the following error:

System.Runtime.InteropServices.COMException (0x80041098): ERROR 010429: Error in GRID IO: MtVatBldNew: Value range for c:\users\user\appdata\local\temp\arcc79c\ah2014~4\tmp2675 exceeds 100000 . ERROR 010429: Error in GRID IO: and number of unique values exceeds 500 .. ERROR 010236: Error in building VAT. ERROR 010067: Error in executing grid expression. at ESRI.ArcGIS.GeoAnalyst.RasterConversionOpClass.ToRasterDataset(IGeoDataset dataset, String rasterFormat, IWorkspace pWorkspace, String name) at ESRI.APWR.ApHydro.ArcHydroOp.FillSinks(ApLayers& aplayers, Boolean useIsSink, Boolean fillAll, Double fillLimit, ITrackCancel trackCancel, IGPMessage messages, String& exMessage) in C:\Builds\HydroSolutions\10.1_ArcHydro\Sources\ArcHydroTools\src\ApHydro\ArcHydroOp.vb:line 57592 Failed to execute (FillSinks).

I thought this was telling me that the DEM was too large in size, so I tried running the tool again with several subsets by using a polygon to determine the processing extent. This results in the same error and I am not sure why. I have tried the usual fixes (deleting temp files, checking output locations, using the toolbox vs. the toolbar) and the error still occurs.

In order to get the DEM to a smaller size, it was converted from float to integer so I thought the VAT error pertained to that. I reran the tools using the float based DEM and received the same error.

I have also tried using small subsets of the raster to see if that is the problem, and I have the same error.

Can anyone offer insight on this or help me figure out what I am doing wrong?

closed as unclear what you're asking by PolyGeo Nov 20 '17 at 23:26

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • I have the same problem, I suspect the floating spatial analyst license, because it generates interuptions of geoprocessing !! – H kamil Sep 22 '14 at 15:23
  • Is the original file in TIF format? I'm a beginning or intermediate user, but a lot of issues trace back to not-in-TIF. I was trying to use the fill tool on a non TIF raster and receiving error messages. I finally converted it to TIF and it worked just fine afterwards. Hopefully this works. – Will Nov 20 '17 at 21:42
  • What were the precise steps (all tools and parameter values) that you performed to see this error? – PolyGeo Nov 20 '17 at 23:26
2

This is a very common error when using ArcHydro, although the exact text and in which function it appears might differ slightly.

You should check out the answer and comments in Error running Arc Hydro tools function in ArcMap?.

But in short, what is most likely to solve your problem is to store all data and your project on C:/ instead of a network drive.

  • Thanks for the reply. Before I started I made sure all inputs, outputs and workspaces were on the C:/ drive and the error continues. I can get past the sink evaluation tool, it is the fill sinks where I get the VAT error. I believe I have tried all the typical error fixes, do you have any other ideas? – Cameron Mar 27 '14 at 14:34
  • This is the "official error thread" on the archydro forum. Check it out and see if you can catch something new! Keeping short names and paths is also a good thing. – Martin Mar 27 '14 at 14:39
  • Also, from the answer in the linked question: 3. Increase the max number of unique values to render. – Martin Mar 27 '14 at 14:48
  • Thank you Martin, I am having trouble finding things I have not tried. I am not sure what else I can try besides using a different pc. – Cameron Mar 27 '14 at 15:19

Not the answer you're looking for? Browse other questions tagged or ask your own question.