2

My points are disappearing when I zoom in past 300,000 in ArcMap. I tried to repair geometry, but it doesn't fix anything?

I also checked the scale extents and those are turned off. I can export the points to a new shapefile/feature class, but I'd like to not have to do that.

I'm using 10.1 on Windows 7 x64.

  • 2
    Try building or deleting/building the spatial index. – mkennedy Mar 28 '14 at 15:56
2

I'm not sure how familiar you are with ArcMap, but do you have a scale range set on the feature? In the TOC right click on the feature and go to properties and view the General tab:

enter image description here

But I'm assuming this is not the case.


In ArcMap, go to the Customize --> ArcMap Options --> Display Cache and clear the cache.


This ESRI Knowledge Base article says to delete and rebuild your spatial index:

http://support.esri.com/fr/knowledgebase/techarticles/detail/38839

  • Yeah, that was the first thing I checked. – MjonesGEO Mar 28 '14 at 15:31
  • 2
    I added a couple other suggestions. Deleting your display cache and ESRI recommends deleting and recreating the spatial index. Good luck. – ianbroad Mar 28 '14 at 16:02
1

I ended up exporting the file and starting over with a new shape. It seemed to work. It could have been the spatial index since I ended up starting over.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.