1

I did the following:

  1. I installed GeoServer by the installer for Windows as a service and standard folders .
  2. Open http://localhost:8080/geoserver/www/ol-demo.html to test my GeoServer WMS layers and not appear the Google, Yahoo, Earth and WMS layers from my GeoServer service.
  3. I copied into the www folder with examples of OpenLayers beginners, this folder contains the img folder, theme, metadata file, openlayers.js OpenLayers and my code examples from the book.

So I opened and ran http://localhost:8080/geoserver/www/code/chapter_5_ex3_google_layer_mashups.html Google Layer, the overlay of WMS example, not my local layer) .

Questions:

  1. I used the Windows installer, it installed the GeoServer software is it alright? Thus no Tomcat or other container?
  2. What can be wrong in the settings of my GeoServer server to not be serving the layers?

Installed according to the instructions from the official website, to run manually as a service, with personalized folder in the default folder and no attempt worked.

  1. In this example http://localhost:8080/geoserver/www/ol-demo.html it not only calls the WMS layer (which is on my localhost), but also calls Google, Yahoo and Earth these should appear on the map, but don't.

My initial goal is to make the overlay of my WMS layers provided by PostGIS on Google Maps, where I did not succeed. So I decided to use the demo to see if my GeoServer server is working.

Any help is welcome, as I am with this problem for days and I do not know that attempts to do.

  • Try to use the 'preview layer' function in GeoServer. If that works, your layer works. From there, I strongly recommend using Leaflet to set up your maps. You'll write much less code. I have heaps of examples here: github.com/gccgisteam/maps-website – Alex Leith Sep 29 '15 at 0:21
1

First thing GeoServer being a java webapp requires a container. The Windows installer, which is not meant for production use IMHO, contains an embedded version of Jetty which is a servlet container.

That said, it is not GeoServer who is overlaying data onto GoogleMaps it is OpenLayers.

I would suggest to split your concerns:

  1. try a simple OL example to show your data
  2. try to use GMaps as back end and then overlay data from GeoServer
  • To test my geoserver open the file ol-demo coming in the www folder with an example of overlapping layers and nothing appears on the map. – csf Mar 31 '14 at 13:08
  • I never used www/ol-demo.html. When I opened it as with with you nothing appeared. Using Firefox/firebug I saw it would not load veaer and yahoosat layers. By commenting out those layers and updating map.addLayers I was able to see the wms layers.Does that help you get going? – Ralph Dell Mar 31 '14 at 16:45
  • I did the same as you and worked with the example that comes in geoserver. To test I created with layers, I made a simple map without overlay with a WMS layer. The layer appears in the switcher but does not appear on the map. This is correct: 1 - My layers are projected in 4326, which is the default map OL 2 - If I use Google Maps I create a map projection in 900913 and all objects within it will fit to this projection. doubt: When I create a map in OL should use the bounds of the geoserver or pattern for the 900913 projection? – csf Mar 31 '14 at 18:37
  • I checked with Firebug and does not give any error, but the map is blank. – csf Mar 31 '14 at 18:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.