1

We have a complex set of operations running as Add-in's and services that span both ArcMap, ArcServer, and ArcGIS Explorer for Desktop. Currently we are compiling everything under .NET 3.5 but we may need to move to .NET 4.0 to resolve an issue.

All of our code uses ProgressHelper from Explorer for Desktop 10.1 which is strictly a 2.0 framework applicaiton. Normally I'd add the command to the config file but the Add-In's are under ESRI control, not the .NET framework.

Is there a way to modify the ESRI configuration files so that the .NET framework knows that 4.0 is the supportedRuntime environment and allows me to load the 2.0 framework DLL?

As a testing note: ArcMap does have it's own configuration file and in that I do have the Startup section defined for both the 2.0 framework and the 4.0 framework.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.