3

In ArcGIS 10.2 for Desktop, a colleague compressed a file geodatabase and then zipped it and sent it to me via email.

I unzipped it and was unable to add any of the feature classes into my map document.

I received this error: "Open Failed. Error opening feature class. Cannot access secured data."

I uncompressed it in ArcCatalog and got the same error when trying to add the data to ArcMap.

This also happened when the colleague zipped the uncompressed geodatabase.

  • 1
    Try using the GP Compact tool. Sometimes this can help remove lock files if they were accidentally sent with the FGDB. – Mintx Mar 28 '14 at 20:54
  • 1
    @Mintx Compact may not get the same reduction in size as Compress but if lock (sr.lock) files are the problem then the asker may be able to look for and delete them in the file geodatabase folder via Windows Explorer. – PolyGeo Mar 28 '14 at 21:11
  • No sr.lock files. It looks like transferring via Dropbox uncompressed is no problem. But any use of the Compress tool seems to corrupt it somehow. – user28611 Apr 2 '14 at 21:14
  • I have experienced the same error. I've used ArcPy to do a whole bunch admin things (which work) on 1 of 3 feature class in a 10.1 fGDB. I then compress the fGDB and the whole thing goes pear shaped. I can't retrieve the data by any means once it's compressed. – GISI Feb 24 '15 at 6:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.