1

I want to create a polygon feature that will go through the dateline (180 long.) in ArcMap. I am using WGS_1984_Web_Mercator_Auxiliary_Sphere (WKID: 3857) for my data frame and my polygonal feature class is defined with the same projected coordinate system. My feature classes are stored within enterprise geodatabase 10.2.1 (SQL Server Geometry spatial type). However, the same behaviour can be reproduced with the file geodatabase feature class.

From Esri help:

Data in a geographic coordinate system is treated, in a sense, as two-dimensional, at least to the point that there are edges, just as in a projected coordinate system. Generally, the edges are at -180/+180 for the east–west extents, and -/+90 for the north–south extents. These extents are called the "horizon" of the coordinate system.

In a geodatabase, a feature that crosses an edge will be clipped to the horizon. If you are editing features in ArcMap, the data frame's coordinate system will affect what happens to a feature that crosses the +/-180° line. If the data frame is using a geographic coordinate system, that is, the +180 and -180 lines are separated, a feature that crosses outside the horizon will be clipped to the horizon. If the data frame is using a projected coordinate system, with the +/-180° line inside, a feature that crosses it will be split into multiple parts.

I am able to create a polyline feature that crosses the 180° line. A multipart feature is created just as outlined in the Help. When I run the Multipart To Singlepart GP tool, I can verify that my line was originally multipart and is represented in the output feature class as two singlepart features.

However, this doesn't happen when I am trying to create a polygon feature crossing the 180° line. I am getting the error message:

Create The Create Feature task could not be completed. The coordinates or measures are out of bounds.

Why don't polygons get splitted just lines did? Is there any workaround that would help me to achieve my goal?

  • What is your geometry storage type? If it's GEOMETRY, that could be holding you back. – Vince Mar 31 '14 at 13:33
  • Yea, @Vince, that is Geometry, I've mentioned this in the question. I'll try to test this behaviour in a file gdb too. – Alex Tereshenkov Mar 31 '14 at 13:56
  • I get the same error even with file geodatabase feature class. – Alex Tereshenkov Mar 31 '14 at 14:13
  • I was actually thinking GEOGRAPHY (which has antipodal limits), but my fingers were left to their own devices. Seeing the same behavior in FGDB means that this is a "feature" of Desktop. Tech Support may have a solution. – Vince Mar 31 '14 at 14:22
0

I have figured out that in order to split polygons at the 180 line, the data frame coordinate system should be a geographic one (for instance, WGS84). The feature classes themselves can be defined with a projected coordinate system, but the data frame should be in geogprahic coordinate system.

So, it seems as the information in the Help is incorrect because if a data frame is defined in the projected coordinate system, the polygon doesn't get splitted.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.