I am using ArcCatalog 10.1 but I cannot find the option "Enable Attachments" when I right click on a shapefile. Please see the picture below too.

enter image description here

There was another question similar to this in this forum but the solution proposed was to convert shapefile to GDB. Can anyone guide me how to do that? Or is there another way to enable attachments.?

I also converted the shapefile to shapefile stored under geodatabase. See the picture below

enter image description here

However my TestingB.shp also doesnot have the attachments option on right click same as TestingA file.

2 Answers 2


Attachments can be enabled only on feature classes stored within a geodatabase (this can be any type of geodatabase - personal, file, or enterprise). You cannot attach your files to a shapefile because there is no container the data can be stored in.

To convert your shapefile to a geodatabase, you can use a GP tool Feature Class To Feature Class (Conversion) or just right-click the shapefile and choose Export > To Geodatabase (which will start the GP tool dialog box).

  • Yes I did that and put another name and location for output feature class. However in arccatalog I can not see the option for attachments in my new file. I have added what I just did in my question edit
    – azmuhak
    Apr 1, 2014 at 10:45
  • 2
    @azmuhak I think you have misunderstood the advice offered. You need to convert your shapefile to a file geodatabase feature class, not use the Feature Class to Feature Class tool to write out another shapefile. In addition to create attachments you need a Standard or Advanced license because Basic is unable to create the Relationship Class needed to handle the many-to-many.
    – PolyGeo
    Apr 1, 2014 at 11:09
  • Thanks for the reply. I have the advanced license so that should not be a problem. Also I have used Feature Class to Geodatabase (multiple) tool (I think this is the tool you are recommending?) The result is a shape file with a dbf file. In ArcCatalog I can only see the shape file, and the enable attachment is still missing
    – azmuhak
    Apr 1, 2014 at 12:01

First Step

I've attached an image showing what you need to do for the first step. Namely, turn the Shapefile into a Featureclass. A Featureclass can only reside inside a Geodatabase (aka GDB).

Alternately you can create a GDB and import your Shapefile into it by R-click, etc. See this image below.

Step 2

As Alex Tereshenkov said - You can only enable attachments to a Featureclass, which by definition will reside inside a GDB. Shapefiles with attachments are disallowed.

Now you can enable attachments as per normal.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.