0

I am just getting started with learning Dojo and ArcGIS API so please bear with me.

I have an existing prototype of an application that use ArcGIS version 3.5. I am looking at the navigation toolbar sample https://developers.arcgis.com/javascript/jssamples/toolbar_navigation.html and trying to get the Prev Extent and Next Extent functionality work in my application. This sample uses ArcGIS V 3.8. When I copy this sample code and run it locally it works. However since I use V3.5 I changed the below line in this sample and it stopped working.

<script src="http://js.arcgis.com/3.8/"></script> 
<script src="//serverapi.arcgisonline.com/jsapi/arcgis/3.5"></script>

Is this feature only supported in V3.8? How do I get it work with V3.5?

2

The toolbar was updated at 3.6, and that sample will only work with version 3.6 or later. My suggestion would be to update your app to latest version of the API, or at least version 3.6.

https://developers.arcgis.com/javascript/jshelp/new_v36.html https://developers.arcgis.com/javascript/jsapi/navigation-amd.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.