I have more than 80k point data. I have created few buffer from 1 to 5 km of them. Now I want to get the covered area by 1 km to 5 km buffered range. For this I have tried to dissolve those individual buffered file. In ArcGIS 10 it took 6 hours and then replied an error. Also in progress bar it was showing 33% completed. I think this 33% progress is some kind of bug as it stay 6 hours. In QGIS it took 8 hours to complete 61% then stopped. Is there any other way or tools to dissolve those large dataset in a reasonable time?

  • 1
    Possibly duplicate Why is the Dissolve Tool not working? ? – Jens Apr 2 '14 at 8:19
  • 1
    Excellent article on this issue here. @ragnvald works around the bug by splitting up the job into batches using Python (and shares the code). – Simbamangu Apr 2 '14 at 8:25
  • 1
    What is the format of your data? In QGIS you can try the GRASS dissolve tool. But make sure you don't have any invalid geometry. Have you tried the dissolve features directly in the buffer tool (both arcGIS and QGIS have it). Another idea would be to use postgres\postgis. – Alexandre Neto Apr 2 '14 at 8:26
  • @AlexandreNeto ..... I have created the buffer first then I used the dissolve tool. – Devils Dream Apr 2 '14 at 10:04
  • @Simbamangu ....I am not used to with ArcPy. Can you provide a little bit hints how can use the code? – Devils Dream Apr 2 '14 at 10:09

I have seen the stalling symptoms you describe from Dissolve when running with 4Gb RAM, and then used the same parameter values to process without a problem using 12Gb RAM.

If you are able to run a test with more RAM, and find the same, then maybe an upgrade is an option.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.