2

I'm migrating an addin to a 64bit machine using Arcmap 9.3.1. Upon execution, it returns the following error - "[Microsoft][ODBC Driver Manager] The specified DSN contains an architecture mismatch between the Driver and Application". I'm aware through sleuthing that there exists two versions of the odbcad32.exe; one in the System32 folder, and one in sysWOW64. Oracle 11g connections are already set up such that one should be able to configure either driver in the control panel, but upon attempting to configure the necessary driver using the 32 bit version, the very same error occurs. Only the 64 bit tests correctly, but the software uses 32. My question is then - is it possible to point to odbcad32 in the system32 folder, and otherwise, why is it that the ODBC driver might be returning the architecture mismatch error upon configuration in the control panel? I also tried rebuilding the tool source (VB .NET if that matters) in x64 but this did nothing.

  • 1
    It sounds like you do, but just to be sure, do you have both 32bit and 64bit Oracle clients installed? – Evil Genius Apr 9 '14 at 15:11
  • It seems unclear from what the guy currently manning that pc is telling me, so we may try a re-install for both. Any other ideas? – Sleep6 Apr 9 '14 at 15:21
  • Are you using a DSN or a connection string? (Ie. 'Driver={Oracle in OraClient11g_home1}'). If it's the latter then make sure you are pointing at the correct oracle client... on our setups this ends up being in _home2 for 32bit. – Evil Genius Apr 9 '14 at 15:25
  • I believe it's the former. The ODBC data source admin lists Oracle in OraClient11g_home2 as the driver. The add-in lifts connection details (server, user name, password and table) from a plaintext file. Attempted configuration (for the 32bit ver) generates the architecture error on his machine.. perhaps we'll have to re-add it, I'll have to get the details later. – Sleep6 Apr 9 '14 at 15:42
  • 1
    That's getting beyond my limited Oracle knowledge, but it sounds like the oranames configuration isn't setup properly. I believe that the two clients (64 & 32bit) function separately and do not share configuration files, so you may want to check that it was configured as well. – Evil Genius Apr 10 '14 at 11:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.