2

I am a programmer exporting 32-bit floating point GeoTIFF rasters from my own application that my users need to read into ArcGIS. Unfortunately I am not an Arc user myself and have zero expertise with it, so please target comments accordingly.

Arc is reading and locating my rasters properly, but I am having problems making it understand which grid cells are empty. Since all positive and negative floating point numbers are legal data values in my rasters, I am trying to use IEEE NaNs as my NoData values, which I understood to be an accepted practice. Furthermore, as my rasters are often dimensionally large but sparsely populated, I'm trying to get maximal compression out of the TIFF PackBits algorithm (which really likes to see sequences of identical bytes) by making an optimal choice with regard to my particular NaN value. Since any 32-bit float whose exponent bits are all 1 is considered a NaN, I'm using 0xffffffff (32 1-bits) as my NaN value since it's both a valid IEEE NaN and is also 4 identical bytes.

Arc seems to treat my 0xffffffff NaN values as low but legal values, i.e., it renders them as black similarly to the actual low legal data values in my file. How can I get Arc to treat this particular constant (which is of course not a value that can be expressed as a floating point number since it's an actual IEEE NaN) as my NoData value and not render it at all?

Not being an Arc user it's quite possible that I'm just not setting the right display/import options within Arc to get what I want. If someone could explain how to do this that may well solve my problem.

  • How does ArcGIS display your NoData value when you query the image using the identify tool? Also, have you tried right-clicking the raster layer in the table of contents > Properties... > Symbology > Display Background Value <your value> as <No Color>? – Aaron Apr 10 '14 at 21:57
  • How are you setting the NoData value in the TIFF? Are you using ESRI ArcObjects, GDAL or writing as binary using the GeoTiff specification? – Michael Stimson Apr 10 '14 at 22:18
  • Hi Aaron, the identity tool does seem to recognize my empty grid cells -- when I point and click over them the displayed panel entry says NoData, whereas clicks over filled pixels show plausible numeric values. That's a gratifyingly positive development! Unfortunately we still can't figure out any way to get Arc to render these empty cells as anything other than black. We played around with the symbology dialog but nothing we did ever altered the black rendering of the empty cells. – Roger Davis Apr 10 '14 at 23:36
  • ... Initially the Display BG Value box was unchecked and the Value was set to 0 (but grayed out). We tried various things (like checking the box and setting the value to NaN) but nothing made any difference. – Roger Davis Apr 10 '14 at 23:42
  • Hi Michael, I'm writing my own GeoTIFF files byte-for-byte using the TIFF and GeoTIFF specs. Just looked through the latter to see if there's a special NoData GeoTIFF key, but there does not seem to be one. – Roger Davis Apr 10 '14 at 23:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.