1

This question already has an answer here:

I use QGIS 2.2 on Windows 8, and the same QGIS 2.2 has been installed on a computer with Windows Vista.

On the Windows 8 everything works just fine, but something is wrong on the Windows Vista. All the projections that I can choose from on the Windows 8 isn't accessable from the Vista computer?

The national projection that all our data are in, can not be chosen on the Vista? No problem on the Windows 8.

What may we have done wrong? We tried to reinstall QGIS on the Windows Vista, but it didn't help.

Something else we can try?

EDIT: I tried installing QGIS in a folder without blanks, as suggested in a comment below. But the problem is still there. I still can't use the right projection on the Vista. The answer in the other question is too complicated for me.

From the postinstall.log (partly in Swedish):

"C:\QGIS_Valmiera\QGIS" „r inte ett internt kommando, externt kommando,
program eller kommandofil.
OSGEO4W home is C:\QGIS_Valmiera\QGIS Valmiera
Synchronizing CRS database with GDAL/PROJ definitions.
Load srs db from: C:/QGIS_Valmiera/QGIS Valmiera/apps/qgis/./resources/srs.db
QFSFileEngine::open: No file name specified
QFSFileEngine::open: No file name specified
QFSFileEngine::open: No file name specified
QFSFileEngine::open: No file name specified
QFSFileEngine::open: No file name specified
Loading epsg.wkt
0 WKTs loaded
CRS update (inserted:0 updated:0 deleted:3631 errors:0)
No CRS updates were necessary.

marked as duplicate by AndreJ, whuber Apr 11 '14 at 14:09

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Try to install as administrator in a folder without blanks, like C:\QGISValmiera\ – AndreJ Apr 11 '14 at 12:09
  • It's possible, but I don't understand why it works on one computer and not the other. And I'm not good enough with handeling computers to really understand the answer to the linked question. – SoS Apr 11 '14 at 12:12
  • Vista might have different default rights for normal users. And blanks in pathnames still cause problems at some point. – AndreJ Apr 11 '14 at 12:56
  • Can you look for postinstall.log, and include the part about "Synchronizing CRS database" in your question? – AndreJ Apr 14 '14 at 10:40
  • The same error as the others: C:\QGIS_Valmiera\QGIS Valmiera contains a blank. – AndreJ Apr 15 '14 at 8:56