I have been having trouble installing QGIS Valmeira on Windows 7 Professional with SP1. When I installed to the default directory C:\Program Files\QGIS Valmiera\, many of the predefined coordinate projections were not loaded. Several other projections were listed in French.

At Andre's suggestion I then reinstalled to a folder without blanks such as C:\QGIS_Valmeira. This worked fine and brought in the previously missing projections.

I did not have this problem with earlier versions of QGIS like Lisboa. What is going on here? Is this a bug in version 2? If so, it must be causing problems for many other Windows users of QGIS.

  • 1
    I'm sure there would be lots more people complaining if this was the case, I didn't have any of these problems on Win8.1 x64 with either QGIS 2.0 or 2.2 using the default installation path "C:\Program Files\QGIS Dufour" (or Valmiera)
    – chrki
    Apr 12 '14 at 16:34
  • 1
    I have the same problem with a Win7 home edition. I just have a few coordinate projection. The irritating thing is that the same installation works on another win7 professional fine. Both installation directories are d:\QGis
    – Pimpel
    Apr 12 '14 at 19:33
  • Sounds like quietely the same problem: gis.stackexchange.com/questions/92772/…
    – Pimpel
    Apr 12 '14 at 19:40

From your deleted answer to another question:

I am experiencing the same problem with Windows 7 Professional SP1. I am missing several projections, including EPSG:4326, while others are being listed in French.

I have tried both 32-bit and 64-bit installations, as follows:

QGIS-OSGeo4W-2.2.0-1-Setup-x86.exe and QGIS-OSGeo4W-2.2.0-1-Setup-x86_64.exe

The postinstall.log file for the 64-bit install shows the following, starting at line 93:

'"C:\PROGRA~1\QGIS"' is not recognized as an internal or external command, operable program or batch file. 
 OSGEO4W home is C:\PROGRA~1\QGIS Valmiera
 Synchronizing CRS database with GDAL/PROJ definitions.
 Load srs db from: C:/PROGRA~1/QGIS Valmiera/apps/qgis/./resources/srs.db
 QFSFileEngine::open: No file name specified 
 QFSFileEngine::open: No file name specified
 QFSFileEngine::open: No file name specified
 QFSFileEngine::open: No file name specified
 QFSFileEngine::open: No file name specified
 Loading epsg.wkt 0 WKTs loaded
 CRS update (inserted:0 updated:0 deleted:3631 errors:0)
 No CRS updates were necessary.

The CRS synchronization breaks because of the blank after QGIS. The OSGEO4W home vaiable should not contain any blanks. For me, it reads C:\PROGRA~2\QGISDU~1\

It might be related to this ticket:

https://hub.qgis.org/issues/9409 and probably also https://hub.qgis.org/issues/10001

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.