0

I'm fairly new at WCS so bear with me if this is a really stupid question, but I can't really understand the problem. I'm trying to retrieve some DEM data from the Italian Ministry of Environment's freely available datasets, which are structured as a Web Coverage Service.

In the capabilities of the dataset I'm interested into (http://wms.pcn.minambiente.it/wcs/dtm_75m?service=WCS&request=GetCapabilities) it clearly states that the Bounding Box limits are the following:

<ows:WGS84BoundingBox dimensions="2">
<ows:LowerCorner>6.53911455679 35.2154346311</ows:LowerCorner>
<ows:UpperCorner>19.6147808261 47.1364182243</ows:UpperCorner>
</ows:WGS84BoundingBox>

But if I try to send the following GetCoverage request:

http://wms.pcn.minambiente.it/cgi-bin/mapserv.exe?map=/ms_ogc/wcs/dtm_75m.map&service=WCS&version=1.1.2&request=GetCoverage&Identifier=EL.DTM.75M&BoundingBox=10.27,41.80,13.36,43.72,urn:ogc:def:crs:EPSG::4326&format=image/tiff

The server keeps returning me this error:

<ows:ExceptionReport xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"    xmlns:ows="http://www.opengis.net/ows/1.1" version="1.1.2" xml:lang="en-US"  xsi:schemaLocation="http://www.opengis.net/ows/1.1  http://schemas.opengis.net/ows/1.1.0/owsExceptionReport.xsd">
<ows:Exception exceptionCode="width/height" locator="InvalidParameterValue">
<ows:ExceptionText>
 msWCSGetCoverage(): WCS server error. Raster size out of range, width and height of resulting coverage must be no more than MAXSIZE=2048.
</ows:ExceptionText>
</ows:Exception>
</ows:ExceptionReport>

Why is that? Where's the error?

I tried also to swap Lon and Lat duplets or give them in the Cartesian coordinates of the dataset, but to no avail...

1 Answer 1

1

I looks like the service may not be responding to WCS 1.1.2 request parameters. It does respond to a 1.0.0 request even though this version is not advertised like:

WCS 1.0.0 request to DTM_75m service

2
  • Thanks nmtoken: I've tried to modify my query with 1.0.0 instead of 1.1.2 and image/png instead than image/tiff (as it appears the only possibility from the xml you linked), but the server replies with a "mapserv.exe" 1Kb file: I tried to change its extension, but to no avail (it cannot be a geoimage weighting only 1 Kb). Do I need to change something else to make my request compliant to WCS 1.0.0 standards?
    – Mutewinter
    Commented Apr 14, 2014 at 13:16
  • mapserv.exe is possibly an error message (XML/text file); despite the name, try opening in a text editor
    – nmtoken
    Commented Nov 20, 2020 at 17:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.