3

I've updated my ArcGIS desktop version from 10.2 to 10.2.1 and have noticed that when I run the 64 bit version of IDLE I now get an error when trying to import arcpy:

Python 2.7.3 (default, Apr 10 2012, 23:24:47) [MSC v.1500 64 bit (AMD64)] on win32
Type "copyright", "credits" or "license()" for more information.
>>> import arcpy

Traceback (most recent call last):
  File "<pyshell#0>", line 1, in <module>
    import arcpy
  File "C:\Program Files (x86)\ArcGIS\Desktop10.2\arcpy\arcpy\__init__.py", line 24, in <module>
    from arcpy.toolbox import *
  File "C:\Program Files (x86)\ArcGIS\Desktop10.2\arcpy\arcpy\toolbox.py", line 656, in <module>
    from na import AddFieldToAnalysisLayer as AddFieldToAnalysisLayer_na
  File "C:\Program Files (x86)\ArcGIS\Desktop10.2\arcpy\arcpy\na.py", line 26, in <module>
    import _na
  File "C:\Program Files (x86)\ArcGIS\Desktop10.2\arcpy\arcpy\_na.py", line 46, in <module>
    class StreetDirectionsProperties(na.StreetDirectionsProperties):
AttributeError: 'module' object has no attribute 'StreetDirectionsProperties'

So the error seems to come from failing to find a module for the Network Analyst extension, which I see is listed as one of the updated Python features in 10.2.1: (http://resources.arcgis.com/en/help/main/10.2/#/What_s_new_in_ArcGIS_10_2_1/016w0000005v000000/). I'm guessing the 10.2.1 release didn't update both the 32 AND 64 bit versions of Arcpy when installing Python 2.7.5. The version I still have in C:\Python27\ArcGISx6410.2 is 2.7.3, but this seems to now be in conflict with the new install.

Can someone please help me figure out how to correct this issue with IDLE? I really need to be able to run stand-alone 64 bit Arcpy scripts. I'm aware of 64 bit background geoprocessing in ArcMap/ArcCatalog, but this is different. I run heavy lifting stand-alone scripts that must be in the 64 bit version.

  • You could try to install 32 and 64 bit Python yourself python.org/download/releases/2.7.5? – Alex Tereshenkov Apr 14 '14 at 18:41
  • 1
    Did you install the 64-bit background geoprocessing through the setup disk - it's a separate install from ArcMap itself, and I believe that's what updates the 64-bit Python installation (regardless of whether you're using in ArcMap/standalone). – Josh Werts Apr 15 '14 at 12:13
  • I had previously used the 64-bit background geoprocessing (BGGP) installer for 10.2, which created a "Python27/ArcGISx6410.2" folder with Python 2.7.3, then later run the setup for the 10.2.1 ArcGIS Desktop update from a disk image. There was no option to run a patch for 64-bit BGGP, but the install process did add Python 2.7.5 to that Python27 folder. I've looked on the ESRI support site for a specific patch to 10.2.1 BGGP, but could not find one. My solution so far has been to revert to a system restore point before I installed 10.2.1. – user18412 Apr 15 '14 at 15:16
1

I think this may be a Question best posed to Esri's software developers via your local Esri support because it sounds like you are saying that you think they made a mistake when finalizing their 10.2.1 release.

If they did, then I suspect they will be keen to address it, but if they stand by their code, then they may be able to help you with the Python version co-existence that you seek.

  • 1
    Yes, this was solved by posting to ESRI support, where I was able to determine that it was not an issue with their 10.2.1 release, but rather the omission of the latest patch for BG gp by our IT department in their network copy of ESRI installer files. After getting the patch I was able to use 10.2.1 with Python 2.7.5, both 32 and 64 bit. – user18412 Apr 25 '14 at 20:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.