1

Using Qgis Valmiera I would like to create feature labels on a layer that are rotated with a rectancular whitish background.

Using "Labels (deprecated)" and entering an angle does the first part of it but I can't make a rectangular backgound. The "buffer labels" option does something similar but it's too fancy and creates giant PDFs.

Using "Labels" I can easily draw a rectangular background but it seems the option to rotate text has been deprecated. Interestingly I can rotate the backgound frame ...

Is there a way to combine both?

3

Firstly, don't use the 'deprecated' labeling. It's deprecated for a reason ;)

The new labeling functionality does allow for rotation. Simply add a "Rotation" column to your attribute table, start editing the layer, and under the Layer Properties > Labels > Placement > Data Defined, set "Rotation" to the new field you just created. Then click the "Rotate" button on the labeling toolbar, and select the label you want to rotate. Dynamically rotate on the map by moving your mouse. Alternatively, you can select the label, and click the "Change Label" button, then type the rotation manually.

Label Rotation Settings

  • Thank you so much! This answers my initial question. However, the rotation feature works differently in the new version. When I rotate text 91° in the 'deprecated' mode it rotates Text 91°. With the new version, this works up to 90° only. If I enter 91° or more, it rotates x+180°. Any workaraound? Is this a bug? If it's a feature, what's the idea behind? – tanGIS Apr 16 '14 at 16:25
  • when I try to overcome the problem by entering x-180° and get negative values this doesn't work. Seems they do not recognize the prefix :-( – tanGIS Apr 16 '14 at 16:33
  • 3
    By default, the 'new' labeling engine keeps text upright, i.e. legible. To turn this off, go under the Rendering section and set Show upside-down labels to something other than never. – dakcarto Apr 16 '14 at 16:40
  • That's it! Thank you! Not at all user friendly behaviour at all from the program ‌‌… – tanGIS Apr 16 '14 at 18:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.