2

I have polygons with ellipse shape in a SDE Oracle ST_GEOMETRY geodatabase. All those polygons are correctly displayed when in a MapService. But when displayed in a FeatureService, some polygons undergo deformation. It's like they were simplified.

I'm using Oracle 11g and ArcGIS 10.0

enter image description here

  • Likely reason is that feature services don't support ellipse shaped features and they are simplified (the same happens with some advanced symbology): resources.arcgis.com/en/help/main/10.2/index.html#//…. Map services create a rasterized image of the vector data first and send just an image to the client, so the source shape doesn't matter for them. – Alex Tereshenkov Apr 17 '14 at 9:37
  • This is very deceiving!!! How am I supposed to edit my features? – yo_haha Apr 17 '14 at 10:28
  • I am not 100% sure if this is the reason though. You are supposed to use technology that supports this workflow such as a desktop application or a web-based solution with the support for ellipse shaped features. – Alex Tereshenkov Apr 17 '14 at 10:33
  • I'm using the ArcGIS Flex API. Doesn't it support ellipse shapes? – yo_haha Apr 17 '14 at 10:57
  • 1
    It's not the API limitation, it's the feature service limitation (think ArcGIS Server) (if it is, as I said I am just making an educated guess). – Alex Tereshenkov Apr 17 '14 at 11:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.