0

I use OpenLayers/GeoServer on an Ubuntu server. GeoServer runs on Tomcat6. I have a grouplayer of several layers all shown at certain scales. When I click at feature at small scale, the GetFeatureInfo request works. When I zoom in and then click at the same feature, the response from server is empty.

There are no errors in the GeoServer logs or Apache logs. Also when I send that request manually via web browser, the response is empty too. At one layer, there are even two zoom levels working, only the last one is empty. BBox and pixels in request look OK.

>>> zoom >>>

Most probably, the problem isn't in code, but here it is:

info = new OpenLayers.Control.WMSGetFeatureInfo({
        url: 'http://158.196.109.46:8080/geoserver/diplomka/wms', 
        title: 'Identify features by clicking',
        queryVisible: true,
        maxFeatures: 1,
        eventListeners: {
            getfeatureinfo: function(event) {
                map.addPopup(new OpenLayers.Popup.FramedCloud(
                    "chicken",
                    map.getLonLatFromPixel(event.xy),
                    null,
                    event.text,
                    null,
                    true
                ));
            }
        }
    });
    map.addControl(info);
    info.activate();

Proxy.cgi is also set properly I think. I also tried raising Tomcat heap memory, it didn't help. So I really don't know, what should be causing this.

Anybody experienced this, or knows what to do?

  • perhaps you have in your map section a specific zoom defined, so you cannot simply get any features beyond it. – Gery Apr 18 '14 at 7:48
  • Aplication worked at my laptop at localhost just fine, so this shouldn't be problem, too. I also didn't define any zoom levels. Used zoom levels came from google map I think. – user3297762 Apr 18 '14 at 9:28
  • I don't work with geoserver so I can't be of much help here probably, you can try firebug to see what the net tab says after requesting features at different zoom levels. – Gery Apr 18 '14 at 9:53
  • turn up logging and look to see what it says. It may be that you clicked where there is no data? – Ian Turton Apr 18 '14 at 16:43
  • Did you figure out what the problem was? – Mike001 May 16 '14 at 17:18
1

Problem was in SLD style. Somehow the value of min and max scale denominator was aproximated during the getfeatureinfo request. When I widened interval of scale levels, the problem was gone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.