7

just upgraded my Kubuntu from 13.10 to 14.04 LTS and lost all plugins. Found out that "python-qgis-common" is not installed.

Tried to install it but was told that it depends on "sip-api-10.1" which cannot be installed. Searched the web and according to almost all ubuntu sites the "sip-api-10.1" is virtual package provided by "python-sip" which is installed (sip4 (4.15.5-1build1) trusty).

BTW, I also had problem with libspatialite3 - had to find libspatialite3_3.1.0~rc2-2_i386 on launchpad and manually install it.

Have 32bit Kubuntu, use standard QGIS repos:

deb http://qgis.org/debian trusty main deb-src http://qgis.org/debian trusty main

and have absolutely no idea what is wrong. I also performed autoclean after distro upgrade.

Do you know any solution of this situation?

  • 2
    Having same issue in Ubuntu 14.04. Anxiously awaiting any responses. (Odd thing is that it worked in the 14.04 pre-release.) Also installing from Ubuntu Software center will not work either. – user261066 Apr 18 '14 at 15:23
6

The package has been rebuild to solve this. Check again.

First add repositories from QGIS:

sudo su
echo deb     http://qgis.org/debian trusty main >> /etc/apt/sources.list
echo deb-src http://qgis.org/debian trusty main >> /etc/apt/sources.list
exit

Then:

sudo apt-get update
sudo apt-get install qgis python-qgis
|improve this answer|||||
  • I was able to install all qgis components like this, but then get errors for gdal: "gdal_translate was compiled against GDAL 1.10 but current library version is 1.11" This also applies to gdal from the terminal. Any solution to this? – – mace Aug 12 '14 at 13:16
  • I tried to fix this be removing gdal and reinstalling it. This bricked QGIS again. After that I tried with recompiling gdal from source: gis.stackexchange.com/a/21739/17399 which solved this problem. Now everything is running fine. – mace Aug 27 '14 at 13:49
2

On Ubuntu 14.04, Python-sip-4.15.5 now provides sip-api-11.0. But python-qgis-common looks for sip-api-10.1. It thinks sip-api is not installed at all.

Sip-api-11.0 was released on the 18th March. Clearly, some programs relying on it have not been updated to reflect this change.

"..., all packages that depend on sip-api- or sip-py3api-* should be rebuilt to pick up new dependency names." - Dmitry Shachnev

Hopefully, this will be fixed soon.

References:

http://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg1211376.html

http://packages.ubuntu.com/trusty/python/python-qgis-common

|improve this answer|||||
  • 1
    While this may be useful information, it is not a solution to the problem presented. – Luís de Sousa May 7 '14 at 7:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.