0

Using ArcGIS Desktop 10.2.1. I have a set of about 600 points that I’m using as the flag input on the trace geometric network tool. Every time I ran the tool with these points, it crashes, along with ArcMap or ArcCatalog, whichever its being run from. I began isolating the points/flags and found that it was crashing only on certain points. Since the crash doesn’t provide any information on the cause, I have no way of knowing what’s causing it or whats different about these points that's causing it to crash. Has anyone experienced an issue like this? The crash occurs on any trace task type.

The points are in NAD83 State Plane and stored in a file gdb. I have been able to isolate a few points that cause the crash and yes, when I run it on one of those points, it crashes. It works fine on the rest of the points. I have not been able to figure out the difference between the points that cause the crash and the ones that don't. The issue occurs on the trace tool in modelbuilder. When I run the trace tool outside of modelbuilder, I experience similar results where the good point(s) run fine, however, the bad point(s) generate error 999999 "Invalid network element id". I have not found any google information on this. All the "invalid network element id" search results refer to reconciling data, which I'm not doing.

  • 1
    You need to provide more detail. What coordinate systems are the points/network? What storage format are they stored in? Can you crash it with just 1 one point? What's different about that point with one that does not crash it? How are you running these tools, via model builder, if so you need to upload at least an image of this? – Hornbydd Apr 22 '14 at 15:30
  • 1
    OK are the single points actually multi-points? There are lots of optional parameters to the Trace tool are you using any of them? – Hornbydd Apr 22 '14 at 20:31
  • Negative, the single points are single points. Also did a bit more investigating on a computer running 10.1 and when I run the trace on the trouble points, the trace results are wrong, far from the actual point. Furthermore, the trace results for all the trouble points are the same even though the points are scattered. So to summarize, the trace results, when run individually on the trouble points, are identical to each other and wrong. – Steve Apr 22 '14 at 20:34
0

While the original issue still exists, I have managed a workaround. The flags were the midpoints of line features. I changed it to the start point of line features and it now works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.