I have some georeferenced pdf's that I would like to open in QGIS. I have read that GDAL version 1.8 and higher will support pdf, and I have GDAL 1.10 installed with QGIS 2.0 on Windows 7, but when I add raster layer then choose my pdf file, I get an error that my file is not a supported source.

  • In the OSGEO4W Shell, can you navigate to your Geopdf, run gdalinfo on it, and insert the output in your question?
    – AndreJ
    Commented Apr 22, 2014 at 4:15
  • gdalinfo gave me "ERROR 4: 092F088.pdf not recognized as a supported format. GDALINFO failed - unable to open 092F088.pdf"
    – mapdaddy
    Commented Apr 23, 2014 at 9:06
  • the file is not corrupt I can open in adobe reader and also works in Avenza pdf maps app for android.
    – mapdaddy
    Commented Apr 23, 2014 at 9:12
  • If gadlinfo can not open it, it might not be a GeoPDF, but a simple pdf; or only working with Avenza. You have to georeference it manually.
    – AndreJ
    Commented Apr 23, 2014 at 9:48
  • It is georeferenced I can see my location on the map in Avenza. Is there any other way to tell if its georeferenced? Any suggestion on how to georeference it since I cant open it in qgis.
    – mapdaddy
    Commented Apr 24, 2014 at 4:37

2 Answers 2


I downloaded probably the same pdf from http://pub.data.gov.bc.ca/datasets/177864/pdf/092f/092F088.pdf Then I run gdalinfo with GDAL 1.10 on Windows 7 64-bit. GDAL was installed from gisinternals.com. Gdalinfo finds georeferencing

C:\temp>gdalinfo 092F088.pdf
Driver: PDF/Geospatial PDF
Files: 092F088.pdf
Size is 6600, 4200
Coordinate System is:
GeoTransform =
  383244.8391245987, 3.386857172932951, -4.931834879719495e-005
  5530149.161139191, -5.662418546658723e-005, -3.386719328594231
  NEATLINE=POLYGON ((383498.6035744368 5516178.8426932972,383498.89611363556 5529895.2499113614,4008
21.16656281275 5529894.7663649889,400821.0596233863 5516178.7470214395,383498.6035744368 5516178.842
Corner Coordinates:
Upper Left  (  383244.839, 5530149.161) (124d37'34.37"W, 49d54'44.33"N)
Lower Left  (  383244.632, 5515924.940) (124d37'18.95"W, 49d47' 3.94"N)
Upper Right (  405598.096, 5530148.787) (124d18'53.88"W, 49d54'58.53"N)
Lower Right (  405597.889, 5515924.566) (124d18'41.41"W, 49d47'18.08"N)
Center      (  394421.364, 5523036.864) (124d28' 7.17"W, 49d51' 1.59"N)
Band 1 Block=6600x1 Type=Byte, ColorInterp=Red
Band 2 Block=6600x1 Type=Byte, ColorInterp=Green
Band 3 Block=6600x1 Type=Byte, ColorInterp=Blue

Then I tried to open the pdf with QGIS 2.0.1 and it fails. Conclusion: We both have a QGIS version that does not support pdf. While awaiting such a build that has the support you can convert geospatial pdf files into GeoTIFFs with gdal_translate by using the binaries from gisinternals. The pdf driver in GDAL is exceptional because write support is compiled by default but for read support GDAL must be especially compiled with libpoppler or libpodofo.

  • The pdf driver used by QGIS (up to 2.4.0 and the OSGEO4W shell as well) is read/write, but the one from gisinternals is rwvs, probably including vector support: gdal.org/frmt_pdf.html
    – AndreJ
    Commented Aug 18, 2014 at 9:33
  • The "v" in the string means Supports: Virtual IO - eg. /vsimem See the full long list of the drivers capabilities with gdalinfo --format pdf
    – user30184
    Commented Aug 18, 2014 at 9:53

The issue should have been fixed for Windows builds with this ticket: http://trac.osgeo.org/osgeo4w/ticket/408 for OSGEO4W GDAL and the QGIS 2.4.0 and dev versions from the setup installer.

gdal_translate works now (it takes some time), even inside QGIS with Raster -> Conversion -> translate, but loading the raster directly never ends. This happens in Windows and Ubuntu version.

Maybe the data is too big for QGIS memory.

See also http://hub.qgis.org/issues/8912

  • No improvement yet with QGIS 2.6.0. Converting with GDAL to some other format is still the best way to go.
    – AndreJ
    Commented Dec 11, 2014 at 6:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.