1

I'm dealing with a very large amount of polygons. Once I join the land use access table to the parcel shapefile, it takes forever for Arc to draw the polygons. I'm trying to select all residential polygons in Harris County, TX from the land parcels.shp joined to the residential table.

Once the polygons I want are selected, I try to export these polygons to a new shapefile. I will not have to deal with any other from the land parcels. The problem is that Arc will create the residential shapefile I badly need for my project , but all it does is create the fields with no attributes in them.

I'm trying to create the Shapefile by right clicking the parcels.shp and trying to export the selected features into a new shapefile.

Any suggestions on why this is happening, and how to get a shapefile of the residential areas with the attribute polygons?

  • How are you creating the shapefile from ArcGIS? – Jason Scheirer Apr 23 '14 at 23:08
3

You should be able to use the Copy Features Tool on the layer with your selection, as long as the out_feature_class parameter is set to the path on disk of where you want the shapefile to be written out it should just work.

  • Using the Copy Features tool creates a shapefile, but I get an ArcMap drawing error saying Cannot acquire a lock. – user26133 Apr 23 '14 at 23:23
  • 2
    This can happen if you have had the database open in Catalog, another ArcMap or Access. Close applications that may be locking. Hint: the MDB has an LDB file that shows who is locking it but not so much which program. Catalog caches information so if you've been there and gone somewhere else it could still be locking. – Michael Stimson Apr 23 '14 at 23:46
  • Have you tried this through ArcCatalog rather than having to do that in ArcMap ? or Perhaps do that in Model Builder ? – PROBERT Apr 24 '14 at 3:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.