1

I have a strange problem in QGIS 2.2 (problem is also present in QGIS 2.1). When I add a point (shapefile) layer, apply graduated style and change point size, everything looks fine. Then I save project, reopen it, and some of the points are missing.

When I open attribute table all points are there, but some of them are not shown on the map. Usually those point are in the middle of the map. I noticed that number of mising points depends on selected "on the fly" CRS (before save). When I remove graduated style then all points show up on the map... Zooming, refreshing view and changing projection doesn't help.

Before save

After save

4
  • 1
    What values do the missing points have? Does it get better if you start your graduate style at 0.9?
    – AndreJ
    Apr 24, 2014 at 7:42
  • I use 5 classes with equal interval from 0.9999 to 1.0002. I tried using 0.9 but it doesn't help. Apr 24, 2014 at 7:51
  • Example of point value: 0.9999017173 Apr 24, 2014 at 7:56
  • Ok, I just tried to change lower value to 0.9 and upper value to 1.1, and it works! This much better solution than the first one I accidentally came up. Is this expected behavior of QGIS, or some kind of bug? Thank you. Apr 24, 2014 at 10:20

1 Answer 1

1

I guess you encountered some kind of rounding error when writing the graduated style to the project file.

Try with some larger intervall, like 0.99 to 1.01

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.