1

We have upgraded from QGis 1.8 to QGis 2.2. Qgis 2.2 is first installed, then 1.8 removed. Since then it is impossible to open .qgs-projects directly from windows explorer. We have checked explorer, file extensions and relinked to C:\Program Files\QGIS Valmiera\bin\qgis.bat . But it doesn't help.

We get the error 'qgis_core.dll cannot be found, please reinstall'. But that is rather drastic.

I use windows xp.

2 Answers 2

1

The file association is a bit crude under Windows 7. It does not like the association with a .bat file, and grabs the qgis-bin.exe in your case.

There are several file associations stored in the registry, which can not be easily accessed from the explorer menu, as it was under Windows XP.

You find the key under

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.qgs\OpenWithList

If you remove all .exe associations from the list, the .qgs should be opened with the bat.

You may find a few utilities here:

https://superuser.com/questions/136133/how-do-i-set-advanced-file-associations-in-windows-7

Or reinstall QGIS 2.2 in a new folder.

3
  • I have the same issue as listed, but on Windows XP, with the same error warning. It's not a Windows 7 only issue. Commented Apr 24, 2014 at 9:36
  • Try to remove the .exe association from the registry, as I explained in my extended answer.
    – AndreJ
    Commented Apr 24, 2014 at 9:48
  • I did manage to solve the problem with removing the .exe associations in the mentioned registry-key. On XP. Thanks Andre! Commented Apr 24, 2014 at 11:28
0

A simple solution is to use the program: Default Programs Editor available from: https://defaultprogramseditor.com/

For example I used the options: File Type Settings -> Context Menu -> QGZ -> QGIS 3.20.1 ; qgis.bin ; QGIS icon

Hope it helps....

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.