I am using ArcGIS Desktop 10.0

I created some customised symbols for my map which ArcGIS Desktop did not have. To do this I used BMP files and imported the symbols.

They look good on the map but do not appear well in the legends when I export the map into any format e.g JPEG.

They either do not appear or appear very light.

What can cause this?

enter image description here

  • Isn't this covered in one of the patches? I think it's called the unreferenced raster patch for v10. Can you confirm that your Arc is up to the latest service pack and fully patched? Apr 25, 2014 at 6:17
  • 1
    Does this sound like your problem? support.esri.com/en/knowledgebase/techarticles/detail/30753
    – PolyGeo
    Apr 25, 2014 at 6:36
  • @Michael Miles-Stimson Im using arcgis desktop 10 and license manager 10... thats all I know... I tried to check using arc's patchfinder n this is what it gave.
    – Ade'l
    Apr 25, 2014 at 6:38
  • Sorry nothing came up. You are saying they look great on the display in map view but when you export them they look different, is that right? Sounds like @polygeo hit the nail on the head, but that's 9.2, it could be the 'vectorize.. with fills' that is the problem. Apr 25, 2014 at 6:44
  • @polygeo that seems to b the issue... yes u r right... I have tried emf n there seems to b some issue with arcgis... as I have prob in exporting.
    – Ade'l
    Apr 25, 2014 at 7:10

1 Answer 1


The symptoms that you describe seem to be those of Bug NIM003653 which is discussed in Knowledge Base Article 30753 (Picture symbol legend patches, inserted images, and objects fail to draw when exported to PDF, EPS, AI, and SVG).

See that Technical Article for full details but the key information is:


If the inserted object, image, or legend patch falls outside the default page size of the Windows default printer, Windows GDI drawing calls used by ArcMap may not properly draw the object or image on output.


On some printers, selecting 'Use Printer Paper Settings' in the Page and Print Setup dialog box alleviates the problem. See the link in the Related Information section for more information on how to use the Use Printer Paper Settings option.

Alternatively, set the Windows default printer's default page size to a page size as large as or larger than the page layout that is being exported. For example, if the map document is a tabloid size (17 x 22) set the default printer's default page size to 17 x 22 or larger before opening ArcMap.

Further information can be found in the ArcGIS Discussion Forums where an Esri staff member says:

If it is [NIM003653: Picture marker symbols or EMF pictures on the layout can fail to draw on output.], then this is not going to be fixed, as it is a limitation of Windows GDI.

It will be interesting to see whether this is an issue with ArcGIS Pro when that is released with ArcGIS 10.3 for Desktop.

  • thx for this useful post. But if I had an issue with all the symbols on the map then I could think of this as an issue but as mentioned in comments too, my display of symbols over the map is good but in legend it appears problematic. there needs to be some way out to this. what do u think...?
    – Ade'l
    Apr 25, 2014 at 7:52
  • 1
    @Ade'l I have not encountered this problem personally, but I note that the Technical Article makes no mention of any issues with symbology in Data Frames, only in the legend patches etc. This may be a Question that you should pursue through your local Esri support, if only to clarify whether it is the bug (or known limit) mentioned here and to determine whether it will also be an issue in ArcGIS Pro.
    – PolyGeo
    Apr 25, 2014 at 7:59
  • 2
    That's interesting, I use CutePDF as my default printer with a page size of Oversize A0 - mostly because I accidentally print some files instead of editing them but partly because I had a problem a few years ago and part of the ESRI support was to check the printer settings and CutePDF fixed it. The export functions are tied to the printer so this could be the root cause of the problem.. perhaps in desperation @Ade'l you could try one of the print-to-pdf printers that is available. Apr 25, 2014 at 8:05
  • 1
    @Michael Miles-Stimson now thats a good piece of advice... ;) yes it worked. Though I used xps writer. One more thing worth noting is that when I added a pseudo layer for legend, and gave it a little transparency, symbols for one of the maps were shown up in legend too! although with other maps, partial visibility occurred...
    – Ade'l
    Apr 25, 2014 at 9:55
  • @polyGeo Thank you for the help. I learnt much from that article of yours... Ill surely look deeper into the issue. :)
    – Ade'l
    Apr 25, 2014 at 9:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.