I have numerous layers in shapefile format that contain a lot of data across a large area.

I am trying to create a .pdf file that shows all of the area and I want it to be in good quality, so that the detail is still there when zoomed in.

I tried to use the QGIS print compressor but it won't allow me to produce the best quality because the document is too big and opening it in high resolution results in an error. Is there another way to make a .pdf from my map layers?

  • Define what a 'very large area' is? For very large datasets, a PDF-print may indeed be ridiculously large, depending on what resolution you're after. Does it all have to be in one image, or could a 'mapbook' (Atlas in QGis) help you here? Commented Apr 30, 2014 at 10:18

2 Answers 2


Try printing to pdf, but set the page size to 24x36 (or a larger sheet of preferred), and make all the font as small as possible (font size 4 or 5). When you print to pdf, keep all of the settings on normal, not high-quality.

You should be able to open up the pdf an zoom in and see details.

thanks and good luck


A similar problem occurred in ArcMap, when I had originally saved my 36 x 24 map as a .pdf, with many complex layers. By saving it this way, it made the .pdf file size huge, and drew the layers individually.

To counter this, you can always use the 'print to .pdf', as previously suggested. Another file format that allows for you to control the formatting is saving it as a .png file.

enter image description here

This allows you to change the resolution (in dpi) or the size manually. From this, you can also make a .pdf if that is the final file type that you want. This method will flatten the layers so they won't draw individually, keeping the file size low, but it will also maintain the desired quality.

This is an Arc screenshot, however you should be able to edit these parameters in QGIS, as well as any photo editing software in general.

  • 1
    thanks, you saved my day! i didnt think about make it as image.
    – Jordan
    Commented May 1, 2014 at 18:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.